summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--dooble.sh4
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9661838933a..a34a0055f416 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dooble-bin
pkgdesc = Web browser based on QtWebEngine
pkgver = 2023.11.30
- pkgrel = 3
+ pkgrel = 4
url = https://textbrowser.github.io/dooble
arch = x86_64
license = LicenseRef-Dooble
@@ -65,6 +65,6 @@ pkgbase = dooble-bin
source = dooble.sh
sha256sums = ccbe838464b18cb3ae16580f0173df4346914504bccc6fc14db1bf537eb9da6d
sha256sums = c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd
- sha256sums = fb6e83ced7565462bc103d45bfd82a2ea1fde0b6e549bd8c4c887c5ecd96c2d9
+ sha256sums = 8c1c658ce21dc1f5fe8687c7406b3f263dc53e2498662c538d963644e9dacdf1
pkgname = dooble-bin
diff --git a/PKGBUILD b/PKGBUILD
index af9159db9531..c681db32cd51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=dooble-bin
_pkgname=Dooble
pkgver=2023.11.30
-pkgrel=3
+pkgrel=4
pkgdesc="Web browser based on QtWebEngine"
arch=("x86_64")
url="https://textbrowser.github.io/dooble"
@@ -79,12 +79,12 @@ source=(
)
sha256sums=('ccbe838464b18cb3ae16580f0173df4346914504bccc6fc14db1bf537eb9da6d'
'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd'
- 'fb6e83ced7565462bc103d45bfd82a2ea1fde0b6e549bd8c4c887c5ecd96c2d9')
+ '8c1c658ce21dc1f5fe8687c7406b3f263dc53e2498662c538d963644e9dacdf1')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|${_pkgname}|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.zst"
+ bsdtar -xf "${srcdir}/data."*
cp "${srcdir}/opt/${pkgname%-bin}/Translations/${pkgname%-bin}_zh_CN_simple.qm" \
"${srcdir}/opt/${pkgname%-bin}/Translations/${pkgname%-bin}_zh_CN.qm"
sed "s|/usr/bin/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
@@ -95,4 +95,4 @@ package() {
install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 "${srcdir}/usr/share/pixmaps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
-}
+} \ No newline at end of file
diff --git a/dooble.sh b/dooble.sh
index e339ae4514e4..1b5f4c55f6e7 100644
--- a/dooble.sh
+++ b/dooble.sh
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR=/opt/@appname@
_RUNNAME="${_APPDIR}/@runname@"
@@ -14,4 +14,4 @@ export QT_X11_NO_MITSHM=1
export QTWEBENGINE_LOCALES_PATH="${_APPDIR}/qtwebengine_locales:${QTWEBENGINE_LOCALES_PATH}"
export QT_PLUGIN_PATH="${_APPDIR}/plugins:${QT_PLUGIN_PATH}"
cd "${_APPDIR}"
-exec "${_RUNNAME}" "$@" | exit $? \ No newline at end of file
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file