summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--[-rwxr-xr-x]PKGBUILD119
-rw-r--r--doom3-dedicated.launcher (renamed from doom3-dedicated.sh)7
-rw-r--r--[-rwxr-xr-x]doom3-dedicated.launcher64 (renamed from doom3-dedicated_64.sh)7
-rw-r--r--doom3.desktop10
-rw-r--r--[-rwxr-xr-x]doom3.install82
-rw-r--r--doom3.launcher (renamed from doom3.sh)7
-rw-r--r--[-rwxr-xr-x]doom3.launcher64 (renamed from doom3_64.sh)7
8 files changed, 162 insertions, 103 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31ce674b82df..ce50c5062341 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,27 @@
pkgbase = doom3
pkgdesc = Doom 3 Engine. You need the retail .pk4 files to play.
pkgver = 1.3.1.1304
- pkgrel = 2
+ pkgrel = 3
url = http://www.doom3.com/
install = doom3.install
arch = i686
arch = x86_64
license = custom:"DOOM 3"
license = custom:"PunkBuster"
- source = http://www.1337-server.net/doom3/doom3-linux-1.3.1.1304.x86.run
- source = doom3.sh
- source = doom3-dedicated.sh
- source = doom3_64.sh
- source = doom3-dedicated_64.sh
- source = doom3.png
+ source = doom3.launcher
+ source = doom3-dedicated.launcher
source = doom3.desktop
- md5sums = 6325f0936f59420d33668754032141cb
- md5sums = 18c6802eee15ad499e2fd3ae03d641a6
- md5sums = da4e827e7ddec2209bf832db5cd3ab74
- md5sums = b8e0aa217e4df414f009fe99448b49bb
- md5sums = f7c57e01b2c97b6e808add668c68ef36
+ source = doom3.launcher64
+ source = doom3-dedicated.launcher64
+ source = doom3.png
+ source = http://www.1337-server.net/doom3/doom3-linux-1.3.1.1304.x86.run
+ md5sums = 29335683bcc2c3063bd9af015025cc38
+ md5sums = a13dc5cdb4b0f6ead3344673b185c53d
+ md5sums = facb0291279621d997f9504924d7e9b1
+ md5sums = 15d33c9f7e1b1c3d2f8cb01c9e68ed97
+ md5sums = bfeb2be83024d60ccda658e4d60b6e13
md5sums = f99eb141eecc4b9dd188d6819d741546
- md5sums = a8a6c7b7befff52cbb6c766466ee4ce9
+ md5sums = 6325f0936f59420d33668754032141cb
pkgname = doom3
diff --git a/PKGBUILD b/PKGBUILD
index 0c94edaac7b2..2cef922ca03c 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,90 @@
+# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
# Contributor: teddy_beer_maniac <teddy_beer_maniac@wp.pl>
+# Contributor: Babets <babetz [at] gmail [dot] com>
pkgname=doom3
pkgver=1.3.1.1304
-pkgrel=2
-pkgdesc="Doom 3 Engine. You need the retail .pk4 files to play."
-url="http://www.doom3.com/"
-license=('custom:"DOOM 3"' \
- 'custom:"PunkBuster"')
-[ "$CARCH" = "i686" ] && depends=('libxext' 'libgl' 'alsa-lib>=1.0.6')
+pkgrel=3
+pkgdesc='Doom 3 Engine. You need the retail .pk4 files to play.'
+url='http://www.doom3.com/'
+license=('custom:"DOOM 3"' 'custom:"PunkBuster"')
+[ "$CARCH" = "i686" ] && depends=('libxext' 'libgl' 'alsa-lib>=1.0.6')
[ "$CARCH" = "x86_64" ] && depends=('lib32-libxext' 'lib32-libgl' 'lib32-alsa-lib>=1.0.6')
arch=('i686' 'x86_64')
-install="doom3.install"
-source=(http://www.1337-server.net/doom3/$pkgname-linux-$pkgver.x86.run \
- $pkgname.sh $pkgname-dedicated.sh $pkgname"_64.sh" $pkgname-dedicated_64.sh
- doom3.png doom3.desktop)
-md5sums=('6325f0936f59420d33668754032141cb'
- '18c6802eee15ad499e2fd3ae03d641a6'
- 'da4e827e7ddec2209bf832db5cd3ab74'
- 'b8e0aa217e4df414f009fe99448b49bb'
- 'f7c57e01b2c97b6e808add668c68ef36'
- 'f99eb141eecc4b9dd188d6819d741546'
- 'a8a6c7b7befff52cbb6c766466ee4ce9')
+install=doom3.install
+source=('doom3.launcher' 'doom3-dedicated.launcher' 'doom3.desktop' \
+'doom3.launcher64' 'doom3-dedicated.launcher64' 'doom3.png' \
+"http://www.1337-server.net/doom3/$pkgname-linux-$pkgver.x86.run")
+md5sums=('29335683bcc2c3063bd9af015025cc38'
+ 'a13dc5cdb4b0f6ead3344673b185c53d'
+ 'facb0291279621d997f9504924d7e9b1'
+ '15d33c9f7e1b1c3d2f8cb01c9e68ed97'
+ 'bfeb2be83024d60ccda658e4d60b6e13'
+ 'f99eb141eecc4b9dd188d6819d741546'
+ '6325f0936f59420d33668754032141cb')
build() {
- cd $startdir/src
- chmod +x $pkgname-linux-$pkgver.x86.run
- mkdir -p $startdir/pkg/opt/$pkgname $startdir/pkg/usr/bin $startdir/pkg/usr/share/licenses/$pkgname
- ./$pkgname-linux-$pkgver.x86.run -- -i $startdir/pkg/opt/$pkgname -b $startdir/pkg/usr/bin
- # ncurses & gtk installers don't return 1 when canceled, so check that files are installed
- ls $startdir/pkg/opt/$pkgname/base || return 1
- if [ "$CARCH" == "i686" ]; then
- install -m755 -D $pkgname.sh $startdir/pkg/opt/$pkgname/$pkgname
- install -m755 -D $pkgname-dedicated.sh $startdir/pkg/opt/$pkgname/$pkgname-dedicated
- else
- install -m755 -D $pkgname"_64.sh" $startdir/pkg/opt/$pkgname/$pkgname
- install -m755 -D $pkgname-dedicated_64.sh $startdir/pkg/opt/$pkgname/$pkgname-dedicated
- fi
-
- ln -sf /opt/$pkgname/$pkgname $startdir/pkg/usr/bin/$pkgname
- ln -sf /opt/$pkgname/$pkgname-dedicated $startdir/pkg/usr/bin/$pkgname-dedicated
- ln -sf /opt/$pkgname/License.txt $startdir/pkg/usr/share/licenses/$pkgname/License.txt
- ln -sf /opt/$pkgname/pb/PB_EULA.txt $startdir/pkg/usr/share/licenses/$pkgname/PB_EULA.txt
-
- mkdir -p $startdir/pkg/usr/share/pixmaps $startdir/pkg/usr/share/applications
- install -m644 -D doom3.png $startdir/pkg/usr/share/pixmaps
- install -m644 -D doom3.desktop $startdir/pkg/usr/share/applications
+ cd $srcdir
+
+ # Create Destination Directories
+ install -d $pkgdir/opt/doom3/{base,d3xp,pb/htm}
+
+ # Make Installer Executable
+ chmod +x $srcdir/doom3-linux-$pkgver.x86.run
+
+ # Extract Game Files
+ ./doom3-linux-$pkgver.x86.run --tar xf
+
+ # Install Game Files
+ install -m 644 base/* $pkgdir/opt/doom3/base
+ install -m 644 d3xp/* $pkgdir/opt/doom3/d3xp
+ install -m 644 pb/htm/* $pkgdir/opt/doom3/pb/htm
+ install -m 644 {CHANGES,README,version.info} $pkgdir/opt/doom3
+
+ # Install Game Libraries
+ install -m 755 $srcdir/{libgcc_s.so.1,libstdc++.so.6} \
+ $pkgdir/opt/doom3
+
+ # Install Punkbuster Libraries
+ install -m 755 $srcdir/pb/{pbag.so,pbags.so,pbcl.so,pbcls.so,pbsv.so} \
+ $pkgdir/opt/doom3/pb
+
+ # Install Game Binaries
+ install -m 755 $srcdir/bin/Linux/x86/{doom.x86,doomded.x86} \
+ $pkgdir/opt/doom3
+
+ if [ "$CARCH" == "i686" ]; then
+ # Install Game Launcher (Client)
+ install -D -m 755 $srcdir/doom3.launcher \
+ $pkgdir/usr/bin/doom3
+
+ # Install Game Launcher (Server)
+ install -D -m 755 $srcdir/doom3-dedicated.launcher \
+ $pkgdir/usr/bin/doom3-dedicated
+ else
+ # Install Game Launcher (Client)
+ install -D -m 755 $srcdir/doom3.launcher64 \
+ $pkgdir/usr/bin/doom3
+
+ # Install Game Launcher (Server)
+ install -D -m 755 $srcdir/doom3-dedicated.launcher64 \
+ $pkgdir/usr/bin/doom3-dedicated
+ fi
+
+ # Install License (DOOM 3)
+ install -D -m 644 $srcdir/License.txt \
+ $pkgdir/usr/share/licenses/$pkgname/license.txt
+
+ # Install License (Punkbuster)
+ install -D -m 644 $srcdir/pb/PB_EULA.txt \
+ $pkgdir/usr/share/licenses/$pkgname/PB_EULA.txt
+
+ # Install Icon
+ install -D -m 644 $srcdir/doom3.png \
+ $pkgdir/usr/share/pixmaps/doom3.png
+
+ # Install Desktop File
+ install -D -m 644 $srcdir/doom3.desktop \
+ $pkgdir/usr/share/applications/doom3.desktop
}
diff --git a/doom3-dedicated.sh b/doom3-dedicated.launcher
index 2e9ff476fa9c..81f7b696035f 100644
--- a/doom3-dedicated.sh
+++ b/doom3-dedicated.launcher
@@ -1,4 +1,7 @@
-#!/bin/sh
-cd /opt/doom3
+#!/bin/bash
+
+cd "/opt/doom3"
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
exec ./doomded.x86 $*
+exit $?
+
diff --git a/doom3-dedicated_64.sh b/doom3-dedicated.launcher64
index 5e6c1fcad3eb..4648bac7abd0 100755..100644
--- a/doom3-dedicated_64.sh
+++ b/doom3-dedicated.launcher64
@@ -1,4 +1,7 @@
-#!/bin/sh
-cd /opt/doom3
+#!/bin/bash
+
+cd "/opt/doom3"
export LD_LIBRARY_PATH="/opt/lib32/usr/lib/:/opt/lib32/lib/:$LD_LIBRARY_PATH:."
linux32 ./doomded.x86 $*
+exit $?
+
diff --git a/doom3.desktop b/doom3.desktop
index 29463fe9e2d8..fe31707c0620 100644
--- a/doom3.desktop
+++ b/doom3.desktop
@@ -1,7 +1,11 @@
[Desktop Entry]
-Type=Application
Encoding=UTF-8
Name=DOOM III
+GenericName=DOOM III
+Comment=
Exec=/usr/bin/doom3
-Categories=Game;ArcadeGame;
-Icon=doom3
+Icon=/usr/share/pixmaps/doom3.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game
diff --git a/doom3.install b/doom3.install
index 6bc2d04e42c4..ef9c4d4d248c 100755..100644
--- a/doom3.install
+++ b/doom3.install
@@ -1,48 +1,50 @@
post_install() {
-cat << EOF
-IMPORTANT
-==> In order to use the software, you have to agree to ID Software's license
-==> located in /opt/doom3/License.txt and Punkbuster's license located in
-==> /opt/doom3/pb/PB_EULA.txt
-==> If you don't, please remove this package (pacman -R doom3)
-IMPORTANT2
-==> If You have x86_64 system and nvidia graphics card, You need to install lib32-nvidia-utils package too.
-==> Thanks jarrebylove.
-
-EOF
-
-cat <<-00installInstructions00
-The following files need to be copied from the win32 install CDs
-to your base/ directory ( md5 sums provided below as reference )
-by default, /opt/doom3/base
-
-71b8d37b2444d3d86a36fd61783844fe base/pak000.pk4
-4bc4f3ba04ec2b4f4837be40e840a3c1 base/pak001.pk4
-fa84069e9642ad9aa4b49624150cc345 base/pak002.pk4
-f22d8464997924e4913e467e7d62d5fe base/pak003.pk4
-38561a3c73f93f2e6fd31abf1d4e9102 base/pak004.pk4
-
-If you are also installing the Resurrection of Evil Expansion Pack,
-you need to copy the following file to your d3xp/ directory
-by default, /opt/doom3/d3xp
-
-a883fef0fd10aadeb73d34c462ff865d d3xp/pak000.pk4
-
-Localization is not supported on Linux ( only english ), you should not copy over any of the zpak files.
-
-Start the game with the command: doom3
-Start the dedicated server with the command: doom3-dedicated
-
-If installed, you can start the Expansion Pack directly from the command line with the command: doom3 +set fs_game d3xp
-Or you can select it in the mods menu of the base game.
+ echo "==> "
+ echo "==> IMPORTANT "
+ echo "==> In order to use the software, you have to agree to ID Software's license "
+ echo "==> located in /opt/doom3/License.txt and Punkbuster's license located in "
+ echo "==> /opt/doom3/pb/PB_EULA.txt "
+ echo "==> If you don't, please remove this package (pacman -R doom3) "
+ echo "==> IMPORTANT2 "
+ echo "==> If You have x86_64 system and nvidia graphics card, You need to install lib32-nvidia-utils package too. "
+ echo "==> Thanks jarrebylove. "
+ echo "==> "
+ echo "==> The following files need to be copied from the win32 install CDs "
+ echo "==> to your base/ directory ( md5 sums provided below as reference ) "
+ echo "==> by default, /opt/doom3/base "
+ echo "==> "
+ echo "==> 71b8d37b2444d3d86a36fd61783844fe base/pak000.pk4 "
+ echo "==> 4bc4f3ba04ec2b4f4837be40e840a3c1 base/pak001.pk4 "
+ echo "==> fa84069e9642ad9aa4b49624150cc345 base/pak002.pk4 "
+ echo "==> f22d8464997924e4913e467e7d62d5fe base/pak003.pk4 "
+ echo "==> 38561a3c73f93f2e6fd31abf1d4e9102 base/pak004.pk4 "
+ echo "==> "
+ echo "==> If you are also installing the Resurrection of Evil Expansion Pack, "
+ echo "==> you need to copy the following file to your d3xp/ directory "
+ echo "==> by default, /opt/doom3/d3xp "
+ echo "==> "
+ echo "==> a883fef0fd10aadeb73d34c462ff865d d3xp/pak000.pk4 "
+ echo "==> "
+ echo "==> Localization is not supported on Linux ( only english ), you should not copy over any of the zpak files. "
+ echo "==> "
+ echo "==> Start the game with the command: doom3 "
+ echo "==> Start the dedicated server with the command: doom3-dedicated "
+ echo "==> "
+ echo "==> If installed, you can start the Expansion Pack directly from the command line with the command: doom3 +set fs_game d3xp "
+ echo "==> Or you can select it in the mods menu of the base game. "
+ echo "==> "
+ echo "==> For troubleshooting and help, see: "
+ echo "==> http://zerowing.idsoftware.com/linux/ "
+ echo "==> "
+}
-For troubleshooting and help, see:
-http://zerowing.idsoftware.com/linux/
-00installInstructions00
- /bin/true
+post_remove() {
+ echo "==> To completely remove DOOM 3, you will need to manually remove"
+ echo "==> /opt/doom3/ as root"
}
op=$1
shift
+
$op $*
diff --git a/doom3.sh b/doom3.launcher
index eb0802a37da3..f75e20a27e55 100644
--- a/doom3.sh
+++ b/doom3.launcher
@@ -1,4 +1,7 @@
-#!/bin/sh
-cd /opt/doom3
+#!/bin/bash
+
+cd "/opt/doom3"
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
exec ./doom.x86 $*
+exit $?
+
diff --git a/doom3_64.sh b/doom3.launcher64
index 03617a2048d6..90c8269c4324 100755..100644
--- a/doom3_64.sh
+++ b/doom3.launcher64
@@ -1,4 +1,7 @@
-#!/bin/sh
-cd /opt/doom3
+#!/bin/bash
+
+cd "/opt/doom3"
export LD_LIBRARY_PATH="/opt/lib32/usr/lib/:/opt/lib32/lib/:$LD_LIBRARY_PATH:."
linux32 ./doom.x86 $*
+exit $?
+