summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--doom3-phantasm.desktop10
-rw-r--r--doom3-phantasm.sh5
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ca41b5491f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = doom3-phantasm
+ pkgdesc = A Doom 3 mod based on the Phantasm horror movies
+ pkgver = 1.2
+ pkgrel = 5
+ url = http://doom3.filefront.com/file/Phantasm_D3;72040
+ arch = i686
+ arch = x86_64
+ license = custom:doom3-phantasm
+ makedepends = unzip
+ depends = doom3
+ source = ftp://files.mhgaming.com/doom3/mods/phantasm_d3_1.2.zip
+ source = http://ducttape.glenmurphy.com/ducttape0006.zip
+ source = doom3-phantasm.sh
+ source = doom3-phantasm.desktop
+ md5sums = e7ec9729b3a90e29b7ccdda94d9e3463
+ md5sums = b890d978f3bc5b5c8ecbe52e4934e368
+ md5sums = ccfbd73953c480c86bb0b2a6eef0f05f
+ md5sums = 0efbe5d6d7937f1bb275cc908e2ee361
+
+pkgname = doom3-phantasm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee73ba003671
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Paul Bredbury <brebs@sent.com>
+
+pkgname=doom3-phantasm
+pkgver=1.2
+pkgrel=5
+pkgdesc="A Doom 3 mod based on the Phantasm horror movies"
+arch=(i686 x86_64)
+url="http://doom3.filefront.com/file/Phantasm_D3;72040"
+license=('custom:doom3-phantasm')
+depends=('doom3')
+makedepends=('unzip')
+source=(ftp://files.mhgaming.com/doom3/mods/phantasm_d3_${pkgver}.zip
+ http://ducttape.glenmurphy.com/ducttape0006.zip
+ doom3-phantasm.sh
+ doom3-phantasm.desktop)
+md5sums=('e7ec9729b3a90e29b7ccdda94d9e3463'
+ 'b890d978f3bc5b5c8ecbe52e4934e368'
+ 'ccfbd73953c480c86bb0b2a6eef0f05f'
+ '0efbe5d6d7937f1bb275cc908e2ee361')
+
+build() {
+ cd $startdir/src/phantasm_d3
+
+ mkdir -p $startdir/pkg/{opt/doom3/phantasm,usr/share/licenses/$pkgname}
+ cp -r config.spec description.txt guis phantasma.pk4 $startdir/pkg/opt/doom3/phantasm/ || return 1
+ install -m644 ../pak008.pk4 $startdir/pkg/opt/doom3/phantasm/pak999.pk4 || return 1
+ install -m755 -D ../$pkgname.sh $startdir/pkg/usr/bin/$pkgname || return 1
+
+ # Extract custom license
+ sed -n 107,120p "phantasm_d3_${pkgver} readme.txt" | sed 's|^ *||g' \
+ > $startdir/pkg/usr/share/licenses/$pkgname/LICENSE || return 1
+
+ # Desktop entry
+ install -D -m644 $startdir/src/$pkgname.desktop $startdir/pkg/usr/share/applications/$pkgname.desktop || return 1
+}
diff --git a/doom3-phantasm.desktop b/doom3-phantasm.desktop
new file mode 100644
index 000000000000..5e6fff6d1ba9
--- /dev/null
+++ b/doom3-phantasm.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=Doom 3 - Phantasm
+GenericName=
+Comment=Based on the Phantasm horror movies
+Icon=/opt/doom3/doom3.png
+Exec=/usr/bin/doom3-phantasm
+Terminal=false
+Categories=Game;ActionGame;
diff --git a/doom3-phantasm.sh b/doom3-phantasm.sh
new file mode 100644
index 000000000000..3d09e9a9c19d
--- /dev/null
+++ b/doom3-phantasm.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd /opt/doom3
+export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
+exec ./doom.x86 +set fs_game phantasm $*