summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a91275150cfc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dotfiles
+ pkgdesc = A tool to make managing your dotfile symlinks in $HOME easy, allowing you to keep all of them in a single directory.
+ pkgver = 0.6.4
+ pkgrel = 2
+ url = https://github.com/jbernard/dotfiles
+ arch = any
+ license = ISC
+ depends = python
+ depends = python-setuptools
+ source = https://pypi.python.org/packages/source/d/dotfiles/dotfiles-0.6.4.tar.gz
+ md5sums = 6bdf65ce6fe4d7fd7b48091ede656679
+
+pkgname = dotfiles
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bf79c5ad147
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Anton Yermalovich <anton dot yermalovich at gmail dot com>
+# Contributor: Stian Østerhaug <stian.osterhaug@gmail.com>
+
+pkgname=dotfiles
+pkgver=0.6.4
+pkgrel=2
+pkgdesc="A tool to make managing your dotfile symlinks in \$HOME easy, allowing you to keep all of them in a single directory."
+license=('ISC')
+arch=(any)
+depends=('python'
+ 'python-setuptools')
+url=https://github.com/jbernard/dotfiles
+source=(https://pypi.python.org/packages/source/d/dotfiles/dotfiles-$pkgver.tar.gz)
+md5sums=('6bdf65ce6fe4d7fd7b48091ede656679')
+
+build() {
+ cd "$srcdir/dotfiles-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/dotfiles-$pkgver"
+ python setup.py install --root=$pkgdir
+}
+