summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c103d37b85bf..5e93323a404d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dotnet-core-bin
pkgver = 3.0.100
- pkgrel = 2
+ pkgrel = 3
url = https://www.microsoft.com/net/core
arch = x86_64
arch = armv7h
@@ -33,6 +33,18 @@ pkgname = dotnet-host-bin
provides = dotnet-host=3.0.100
conflicts = dotnet-host
+pkgname = dotnet-runtime-bin
+ pkgdesc = The .NET Core runtime (binary)
+ depends = dotnet-host-bin
+ depends = icu
+ depends = krb5
+ depends = libunwind
+ depends = openssl
+ depends = zlib
+ depends = libcurl.so
+ optdepends = lttng-ust: CoreCLR tracing
+ provides = dotnet-runtime=3.0.100
+
pkgname = aspnet-runtime-bin
pkgdesc = The ASP.NET Core runtime (binary)
depends = dotnet-runtime-bin
diff --git a/PKGBUILD b/PKGBUILD
index ffa23ed8819d..4c7aaebf2d15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Attila Greguss <floyd0122[at]gmail[dot]com>
pkgbase=dotnet-core-bin
-pkgname=('dotnet-host-bin' 'aspnet-runtime-bin' 'dotnet-sdk-bin')
+pkgname=('dotnet-host-bin' 'dotnet-runtime-bin' 'aspnet-runtime-bin' 'dotnet-sdk-bin')
pkgver=3.0.100
-pkgrel=2
+pkgrel=3
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.microsoft.com/net/core'
license=('MIT')
@@ -32,19 +32,17 @@ package_dotnet-host-bin() {
install -Dm 755 "${srcdir}"/dotnet.sh "${pkgdir}"/usr/bin/dotnet
}
+package_dotnet-runtime-bin() {
+ pkgdesc='The .NET Core runtime (binary)'
+ depends=('dotnet-host-bin' 'icu' 'krb5' 'libunwind' 'openssl' 'zlib'
+ 'libcurl.so')
+ optdepends=('lttng-ust: CoreCLR tracing')
+ provides=("dotnet-runtime=${pkgver%+*}")
-# runtime-bin already exists in aur, but incomplete
-#package_dotnet-runtime-bin() {
-# pkgdesc='The .NET Core runtime (binary)'
-# depends=('dotnet-host-bin' 'icu' 'krb5' 'libunwind' 'openssl' 'zlib'
-# 'libcurl.so')
-# optdepends=('lttng-ust: CoreCLR tracing')
-# provides=("dotnet-runtime=${pkgver%+*}")
-
-# install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
-# cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/opt/dotnet/shared/
-# ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-runtime
-#}
+ install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/opt/dotnet/shared/
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-runtime
+}
package_aspnet-runtime-bin() {
pkgdesc='The ASP.NET Core runtime (binary)'