summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO108
-rw-r--r--PKGBUILD163
-rw-r--r--dotnet-coreclr-rid.patch38
-rwxr-xr-xdotnet.sh6
4 files changed, 315 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3777dad0d68a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,108 @@
+pkgbase = dotnet-core-preview
+ pkgver = 3.0.0+100+preview.009812
+ pkgrel = 1
+ url = https://www.microsoft.com/net/core
+ arch = x86_64
+ license = MIT
+ makedepends = clang
+ makedepends = cmake
+ makedepends = curl
+ makedepends = git
+ makedepends = icu
+ makedepends = krb5
+ makedepends = libunwind
+ makedepends = lldb
+ makedepends = llvm
+ makedepends = lttng-ust
+ makedepends = openssl
+ makedepends = zlib
+ options = staticlibs
+ source = dotnet-source-build::git+https://github.com/dotnet/source-build.git
+ source = dotnet-application-insights::git+https://github.com/Microsoft/ApplicationInsights-dotnet.git
+ source = dotnet-aspnet-razor::git+https://github.com/aspnet/Razor.git
+ source = dotnet-cecil::git+https://github.com/mono/cecil.git
+ source = dotnet-cli::git+https://github.com/dotnet/cli.git
+ source = dotnet-cli-migrate::git+https://github.com/dotnet/cli-migrate.git
+ source = dotnet-clicommandlineparser::git+https://github.com/dotnet/clicommandlineparser.git
+ source = dotnet-common::git+https://github.com/aspnet/common.git
+ source = dotnet-core-sdk::git+https://github.com/dotnet/core-sdk.git
+ source = dotnet-core-setup::git+https://github.com/dotnet/core-setup.git
+ source = dotnet-coreclr::git+https://github.com/dotnet/coreclr.git
+ source = dotnet-corefx::git+https://github.com/dotnet/corefx.git
+ source = dotnet-fsharp::git+https://github.com/Microsoft/VisualFSharp.git
+ source = dotnet-linker::git+https://github.com/mono/linker.git
+ source = dotnet-msbuild::git+https://github.com/Microsoft/msbuild.git
+ source = dotnet-newtonsoft-json::git+https://github.com/dseefeld/Newtonsoft.Json.git
+ source = dotnet-nuget-client::git+https://github.com/NuGet/NuGet.Client.git
+ source = dotnet-roslyn::git+https://github.com/dotnet/roslyn.git
+ source = dotnet-roslyn-tools::git+https://github.com/dotnet/roslyn-tools.git
+ source = dotnet-sdk::git+https://github.com/dotnet/sdk.git
+ source = dotnet-standard::git+https://github.com/dotnet/standard.git
+ source = dotnet-templating::git+https://github.com/dotnet/templating.git
+ source = dotnet-toolset::git+https://github.com/dotnet/toolset.git
+ source = dotnet-vstest::git+https://github.com/Microsoft/vstest.git
+ source = dotnet-websdk::git+https://github.com/aspnet/websdk.git
+ source = dotnet-xliff-tasks::git+https://github.com/dotnet/xliff-tasks.git
+ source = https://download.visualstudio.microsoft.com/download/pr/d5460b29-cab8-43e6-b939-d150f4119e5e/b6269597f778fb9932925d50e6a0b0ed/aspnetcore-runtime-3.0.0-preview-18579-0056-linux-x64.tar.gz
+ source = dotnet.sh
+ source = dotnet-coreclr-rid.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 1efa641bba4fd458136517f31f9719130fc3c733525d98ab152dc2a9639018c1
+ sha256sums = f4cb02490234b853946477f82514f0c6247b55b08b2e85fae98e99a6e6974edd
+ sha256sums = 2c4fc48151e5319d57c8761091709070a17da91eddc2de8a26bc32c60679bfee
+
+pkgname = dotnet-host-preview
+ pkgdesc = A generic driver for the .NET Core Command Line Interface (preview)
+ provides = dotnet-host
+ conflicts = dotnet-host
+
+pkgname = dotnet-runtime-preview
+ pkgdesc = The .NET Core runtime (preview)
+ depends = dotnet-host-preview
+ depends = icu
+ depends = krb5
+ depends = libunwind
+ depends = openssl
+ depends = zlib
+ depends = libcurl.so
+ optdepends = lttng-ust: CoreCLR tracing
+ provides = dotnet-runtime-3.0
+ conflicts = dotnet-runtime-3.0
+
+pkgname = aspnet-runtime-preview
+ pkgdesc = The ASP.NET Core runtime (preview)
+ depends = dotnet-runtime-preview
+ provides = aspnet-runtime-3.0
+ conflicts = aspnet-runtime-3.0
+
+pkgname = dotnet-sdk-preview
+ pkgdesc = The .NET Core SDK (preview)
+ depends = dotnet-runtime-preview
+ provides = dotnet-sdk-3.0
+ conflicts = dotnet-sdk-3.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c983ef535802
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,163 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Max Liebkies <mail@maxliebkies.de>
+
+pkgbase=dotnet-core-preview
+pkgname=('dotnet-host-preview' 'dotnet-runtime-preview' 'aspnet-runtime-preview' 'dotnet-sdk-preview')
+pkgver=3.0.0+100+preview.009812
+_pkgver=3.0.0+100-preview-009812
+pkgrel=1
+arch=('x86_64')
+url='https://www.microsoft.com/net/core'
+license=('MIT')
+makedepends=(
+ 'clang' 'cmake' 'curl' 'git' 'icu' 'krb5' 'libunwind' 'lldb' 'llvm'
+ 'lttng-ust' 'openssl' 'zlib'
+)
+options=('staticlibs')
+source=(
+ 'dotnet-source-build::git+https://github.com/dotnet/source-build.git'
+ 'dotnet-application-insights::git+https://github.com/Microsoft/ApplicationInsights-dotnet.git'
+ 'dotnet-aspnet-razor::git+https://github.com/aspnet/Razor.git'
+ 'dotnet-cecil::git+https://github.com/mono/cecil.git'
+ 'dotnet-cli::git+https://github.com/dotnet/cli.git'
+ 'dotnet-cli-migrate::git+https://github.com/dotnet/cli-migrate.git'
+ 'dotnet-clicommandlineparser::git+https://github.com/dotnet/clicommandlineparser.git'
+ 'dotnet-common::git+https://github.com/aspnet/common.git'
+ 'dotnet-core-sdk::git+https://github.com/dotnet/core-sdk.git'
+ 'dotnet-core-setup::git+https://github.com/dotnet/core-setup.git'
+ 'dotnet-coreclr::git+https://github.com/dotnet/coreclr.git'
+ 'dotnet-corefx::git+https://github.com/dotnet/corefx.git'
+ 'dotnet-fsharp::git+https://github.com/Microsoft/VisualFSharp.git'
+ 'dotnet-linker::git+https://github.com/mono/linker.git'
+ 'dotnet-msbuild::git+https://github.com/Microsoft/msbuild.git'
+ 'dotnet-newtonsoft-json::git+https://github.com/dseefeld/Newtonsoft.Json.git'
+ 'dotnet-nuget-client::git+https://github.com/NuGet/NuGet.Client.git'
+ 'dotnet-roslyn::git+https://github.com/dotnet/roslyn.git'
+ 'dotnet-roslyn-tools::git+https://github.com/dotnet/roslyn-tools.git'
+ 'dotnet-sdk::git+https://github.com/dotnet/sdk.git'
+ 'dotnet-standard::git+https://github.com/dotnet/standard.git'
+ 'dotnet-templating::git+https://github.com/dotnet/templating.git'
+ 'dotnet-toolset::git+https://github.com/dotnet/toolset.git'
+ 'dotnet-vstest::git+https://github.com/Microsoft/vstest.git'
+ 'dotnet-websdk::git+https://github.com/aspnet/websdk.git'
+ 'dotnet-xliff-tasks::git+https://github.com/dotnet/xliff-tasks.git'
+ 'https://download.visualstudio.microsoft.com/download/pr/d5460b29-cab8-43e6-b939-d150f4119e5e/b6269597f778fb9932925d50e6a0b0ed/aspnetcore-runtime-3.0.0-preview-18579-0056-linux-x64.tar.gz'
+ 'dotnet.sh'
+ 'dotnet-coreclr-rid.patch'
+)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '1efa641bba4fd458136517f31f9719130fc3c733525d98ab152dc2a9639018c1'
+ 'f4cb02490234b853946477f82514f0c6247b55b08b2e85fae98e99a6e6974edd'
+ '2c4fc48151e5319d57c8761091709070a17da91eddc2de8a26bc32c60679bfee')
+
+prepare() {
+ cd dotnet-source-build
+
+ for submodule in src/{application-insights,aspnet-razor,cli,cli-migrate,clicommandlineparser,common,core-sdk,core-setup,coreclr,corefx,fsharp,linker,msbuild,newtonsoft-json,nuget-client,roslyn,roslyn-tools,sdk,standard,templating,toolset,vstest,websdk,xliff-tasks}; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../dotnet-${submodule#src/}
+ git submodule update
+ done
+
+ cd src/linker
+
+ for submodule in cecil; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../../../dotnet-${submodule}
+ git submodule update
+ done
+
+ cd ../coreclr
+
+ patch -Np1 -i "${srcdir}"/dotnet-coreclr-rid.patch
+}
+
+build() {
+ cd dotnet-source-build
+
+ export SOURCE_BUILD_SKIP_SUBMODULE_CHECK=1
+
+ ./build.sh
+}
+
+package_dotnet-host-preview() {
+ pkgdesc='A generic driver for the .NET Core Command Line Interface (preview)'
+ provides=('dotnet-host')
+ conflicts=('dotnet-host')
+
+ cd dotnet-source-build/bin/x64/Release
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses/dotnet-host}
+ tar -C "${pkgdir}"/opt/dotnet -xf dotnet-sdk-${_pkgver/[0-9]\+}-linux-x64.tar.gz ./dotnet ./host
+ tar -C "${pkgdir}"/usr/share/licenses/dotnet-host -xf dotnet-sdk-${_pkgver/[0-9]\+}-linux-x64.tar.gz ./LICENSE.txt ./ThirdPartyNotices.txt
+ chown root:root -R "${pkgdir}"/opt/dotnet
+ install -Dm 755 "${srcdir}"/dotnet.sh "${pkgdir}"/usr/bin/dotnet
+}
+
+package_dotnet-runtime-preview() {
+ pkgdesc='The .NET Core runtime (preview)'
+ depends=('dotnet-host-preview' 'icu' 'krb5' 'libunwind' 'openssl' 'zlib'
+ 'libcurl.so')
+ optdepends=('lttng-ust: CoreCLR tracing')
+ provides=('dotnet-runtime-3.0')
+ conflicts=('dotnet-runtime-3.0')
+
+ cd dotnet-source-build/bin/x64/Release
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses}
+ tar -C "${pkgdir}"/opt/dotnet -xf dotnet-sdk-${_pkgver/[0-9]\+}-linux-x64.tar.gz ./shared
+ chown root:root -R "${pkgdir}"/opt/dotnet
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-runtime
+}
+
+package_aspnet-runtime-preview() {
+ pkgdesc='The ASP.NET Core runtime (preview)'
+ depends=('dotnet-runtime-preview')
+ provides=('aspnet-runtime-3.0')
+ conflicts=('aspnet-runtime-3.0')
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.{All,App} "${pkgdir}"/opt/dotnet/shared/
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/aspnet-runtime
+}
+
+package_dotnet-sdk-preview() {
+ pkgdesc='The .NET Core SDK (preview)'
+ depends=('dotnet-runtime-preview')
+ provides=('dotnet-sdk-3.0')
+ conflicts=('dotnet-sdk-3.0')
+
+ cd dotnet-source-build/bin/x64/Release
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses}
+ tar -C "${pkgdir}"/opt/dotnet -xf dotnet-sdk-${_pkgver/[0-9]\+}-linux-x64.tar.gz ./sdk
+ chown root:root -R "${pkgdir}"/opt/dotnet
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-sdk
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/dotnet-coreclr-rid.patch b/dotnet-coreclr-rid.patch
new file mode 100644
index 000000000000..a0b38a7ee92e
--- /dev/null
+++ b/dotnet-coreclr-rid.patch
@@ -0,0 +1,38 @@
+diff -rupN dotnet-coreclr.orig/build-packages.sh dotnet-coreclr/build-packages.sh
+--- dotnet-coreclr.orig/build-packages.sh 2018-06-21 11:53:45.890536633 +0200
++++ dotnet-coreclr/build-packages.sh 2018-06-21 11:57:34.508917604 +0200
+@@ -24,6 +24,9 @@ initHostDistroRid()
+ if [[ $ID == "alpine" ]]; then
+ __HostDistroRid="linux-musl-$__Arch"
+ fi
++ if [[ $ID == "arch" ]]; then
++ __HostDistroRid="arch-$__Arch"
++ fi
+ elif [ -e /etc/redhat-release ]; then
+ local redhatRelease=$(</etc/redhat-release)
+ if [[ $redhatRelease == "CentOS release 6."* || $redhatRelease == "Red Hat Enterprise Linux Server release 6."* ]]; then
+diff -rupN dotnet-coreclr.orig/build.sh dotnet-coreclr/build.sh
+--- dotnet-coreclr.orig/build.sh 2018-06-21 11:53:45.890536633 +0200
++++ dotnet-coreclr/build.sh 2018-06-21 11:56:19.968359087 +0200
+@@ -73,6 +73,9 @@ initHostDistroRid()
+ if [[ $ID == "alpine" ]]; then
+ __HostDistroRid="linux-musl-$__HostArch"
+ fi
++ if [[ $ID == "arch" ]]; then
++ __HostDistroRid="arch-$__HostArch"
++ fi
+ elif [ -e /etc/redhat-release ]; then
+ local redhatRelease=$(</etc/redhat-release)
+ if [[ $redhatRelease == "CentOS release 6."* || $redhatRelease == "Red Hat Enterprise Linux Server release 6."* ]]; then
+diff -rupN dotnet-coreclr.orig/build-test.sh dotnet-coreclr/build-test.sh
+--- dotnet-coreclr.orig/build-test.sh 2018-06-21 11:53:45.890536633 +0200
++++ dotnet-coreclr/build-test.sh 2018-06-21 11:58:19.189252190 +0200
+@@ -21,6 +21,8 @@ initHostDistroRid()
+ source /etc/os-release
+ if [[ $ID == "alpine" ]]; then
+ __HostDistroRid="linux-musl-$__HostArch"
++ elif [[ $ID == "arch" ]]; then
++ __HostDistroRid="arch-$__HostArch"
+ else
+ __PortableBuild=1
+ __HostDistroRid="$ID.$VERSION_ID-$__HostArch"
diff --git a/dotnet.sh b/dotnet.sh
new file mode 100755
index 000000000000..8efc2b6c762f
--- /dev/null
+++ b/dotnet.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+export DOTNET_ROOT=/opt/dotnet
+exec /opt/dotnet/dotnet $@
+
+# vim: ts=2 sw=2 et: