summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rw-r--r--doublecontact_Qt5_build_bugfixes.patch46
3 files changed, 9 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5369e145d12a..1ab5d30721c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,13 @@
-# Generated by mksrcinfo v8
-# Sun May 5 13:43:40 UTC 2019
pkgbase = doublecontact
pkgdesc = Offline DE-independent contact manager primarily for phonebooks editing/merging
- pkgver = 0.2.0
+ pkgver = 0.2.4
pkgrel = 1
url = https://github.com/DarkHobbit/doublecontact/
arch = x86_64
license = GPL
depends = qt5-base
depends = hicolor-icon-theme
- source = https://github.com/DarkHobbit/doublecontact/archive/0.2.0.tar.gz
- source = doublecontact_Qt5_build_bugfixes.patch
- sha512sums = c24a47038dcfcbc8ae2853e10c2c0bbe12eeb02da999f082a7652109504aa437dacf5fe04bc60c5a9aa2b5e178541f178134a44cffb05dfa398c36b5c5daaf52
- sha512sums = 9bbe2538a5afd04cd9cea42d2eb6919ae300428cba9bd7aeb81bca04a5d8686fef2c220fa4a3757bb6aa817673a55842c27a0c9ca745adb63a4146e2c8a23c88
+ source = https://github.com/DarkHobbit/doublecontact/archive/0.2.4.tar.gz
+ sha512sums = 1e9662f23ed11a9fb5a8d3d0d6ede052263dc947ac7aedb1ef5272d2aaf027acfeb2f3158fcf9f447c9d63ceafdfe7b89126c7d04cab1291cd9ab2b98af20398
pkgname = doublecontact
-
diff --git a/PKGBUILD b/PKGBUILD
index a2a4658ae9c8..6f704af5408c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,15 @@
# Maintainer:
pkgname=doublecontact
-pkgver=0.2.0
+pkgver=0.2.4
pkgrel=1
pkgdesc="Offline DE-independent contact manager primarily for phonebooks editing/merging"
arch=('x86_64')
url="https://github.com/DarkHobbit/doublecontact/"
license=('GPL')
depends=('qt5-base' 'hicolor-icon-theme')
-source=(https://github.com/DarkHobbit/${pkgname}/archive/${pkgver}.tar.gz doublecontact_Qt5_build_bugfixes.patch)
-sha512sums=('c24a47038dcfcbc8ae2853e10c2c0bbe12eeb02da999f082a7652109504aa437dacf5fe04bc60c5a9aa2b5e178541f178134a44cffb05dfa398c36b5c5daaf52'
- '9bbe2538a5afd04cd9cea42d2eb6919ae300428cba9bd7aeb81bca04a5d8686fef2c220fa4a3757bb6aa817673a55842c27a0c9ca745adb63a4146e2c8a23c88')
-
-
-prepare() {
- cd "${pkgname}-${pkgver}"
- patch -Np1 -i ../doublecontact_Qt5_build_bugfixes.patch
-}
+source=(https://github.com/DarkHobbit/${pkgname}/archive/${pkgver}.tar.gz)
+sha512sums=('1e9662f23ed11a9fb5a8d3d0d6ede052263dc947ac7aedb1ef5272d2aaf027acfeb2f3158fcf9f447c9d63ceafdfe7b89126c7d04cab1291cd9ab2b98af20398')
build() {
@@ -32,7 +25,6 @@ package() {
# install visuals
install -D -m644 app/doublecontact.desktop "${pkgdir}/usr/share/applications/doublecontact.desktop"
- #install -D -m644 "img/128x128/doublecontact_128x128.png" "${pkgdir}/usr/share/pixmaps/doublecontact.png"
install -D -m644 "img/32x32/doublecontact_32x32.png" "${pkgdir}/usr/share/pixmaps/doublecontact_32x32.png"
for format in {16x16,32x32,64x64,128x128,256x256,512x512}; do
install -D -m644 "img/${format}/doublecontact_${format}.png" "${pkgdir}/usr/share/icons/hicolor/${format}/apps/doublecontact.png"
@@ -41,5 +33,8 @@ package() {
# install translations
install -D -m644 translations/iso639-1.utf8 "$pkgdir"/usr/share/$pkgname/translations/iso639-1.utf8
install -D -m644 translations/*.qm -t "$pkgdir"/usr/share/$pkgname/translations/
+
+ # install docs
+ install -D -m644 doc/* -t "$pkgdir"/usr/share/$pkgname/doc/
}
diff --git a/doublecontact_Qt5_build_bugfixes.patch b/doublecontact_Qt5_build_bugfixes.patch
deleted file mode 100644
index 61ea5add0bdd..000000000000
--- a/doublecontact_Qt5_build_bugfixes.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 4268b1b3754e1ee9bab3f18e1d94b378d312a51f Mon Sep 17 00:00:00 2001
-From: zv <zv@dhbook.local>
-Date: Fri, 3 May 2019 17:32:41 +0300
-Subject: [PATCH] Qt5 build bugfixes
-
----
- app/doublecontact.pro | 9 +++++----
- core/formats/common/vcarddata.cpp | 2 +-
- 2 files changed, 6 insertions(+), 5 deletions(-)
-
-diff --git a/app/doublecontact.pro b/app/doublecontact.pro
-index d94dee6..a2ee33f 100644
---- a/app/doublecontact.pro
-+++ b/app/doublecontact.pro
-@@ -74,13 +74,14 @@ win32 {
- tr.commands = lrelease \
- $$_PRO_FILE_
- }
--unix&&!macx {
--tr.commands = lrelease-qt5 \
-+unix {
-+macx {
-+tr.commands = lrelease \
- $$_PRO_FILE_
- } else {
--tr.commands = lrelease \
-+tr.commands = lrelease-qt5 \
- $$_PRO_FILE_
--
-+}
- }
- } else {
- tr.commands = lrelease \
-diff --git a/core/formats/common/vcarddata.cpp b/core/formats/common/vcarddata.cpp
-index c2c5f12..e2e621f 100644
---- a/core/formats/common/vcarddata.cpp
-+++ b/core/formats/common/vcarddata.cpp
-@@ -543,7 +543,7 @@ void VCardData::importAddress(PostalAddress &item, const QStringList& aTypes, co
- QStringList VCardData::splitBySC(const QString &src)
- {
- #if QT_VERSION >= 0x050000
-- return QRegularExpression("(?<!\\\\);")).replaceInStrings("\\;", ";");
-+ return src.split(QRegularExpression("(?<!\\\\);")).replaceInStrings("\\;", ";");
- #else
- QStringList res = src.split(";");
- // TODO m.b. after DC 1.0 port this to C++11