summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 433c8b8b561f..e71c2af5206f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dptfxtract-static-bin
pkgdesc = Intel's Linux DPTF Extract Utility for generating thermald's thermal_conf.xml (Statically linked version)
- pkgver = 1.4.3
+ pkgver = 1.4.4
pkgrel = 1
url = https://github.com/intel/dptfxtract
arch = x86_64
@@ -8,8 +8,9 @@ pkgbase = dptfxtract-static-bin
depends = thermald
provides = dptfxtract
conflicts = dptfxtract
- source = https://github.com/intel/dptfxtract/archive/v1.4.3.tar.gz
- sha256sums = b8df8d91c356b553fb82ad9c5a06193a51c872c6f9bb87eeef713cb99c30a82d
+ source = https://github.com/intel/dptfxtract/raw/015f8e845fd9f201d7b9ccb72024da0623cb0514/dptfxtract-static
+ source = https://github.com/intel/dptfxtract/raw/015f8e845fd9f201d7b9ccb72024da0623cb0514/COPYING
+ sha256sums = 9bf19710a7922d06eb8529b2bcacb358c5c616fff7e53a2d75734aa45da9781c
+ sha256sums = f4005b643f5bb944ecd864992e8b4699dd97cb8086301a198be1bcb0728415f0
pkgname = dptfxtract-static-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 19c67e3f49cd..204f8254f9ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=dptfxtract
pkgname="${_pkgname}-static-bin"
-pkgver=1.4.3
+pkgver=1.4.4
pkgrel=1
pkgdesc="Intel's Linux DPTF Extract Utility for generating thermald's thermal_conf.xml (Statically linked version)"
arch=('x86_64')
@@ -11,11 +11,13 @@ license=('custom:Binary License')
provides=('dptfxtract')
conflicts=('dptfxtract')
depends=('thermald')
-source=("https://github.com/intel/dptfxtract/archive/v${pkgver}.tar.gz")
-sha256sums=('b8df8d91c356b553fb82ad9c5a06193a51c872c6f9bb87eeef713cb99c30a82d')
+_commit="015f8e845fd9f201d7b9ccb72024da0623cb0514" # v1.4.4
+source=("https://github.com/intel/dptfxtract/raw/$_commit/dptfxtract-static"
+ "https://github.com/intel/dptfxtract/raw/$_commit/COPYING")
+sha256sums=("9bf19710a7922d06eb8529b2bcacb358c5c616fff7e53a2d75734aa45da9781c"
+ "f4005b643f5bb944ecd864992e8b4699dd97cb8086301a198be1bcb0728415f0")
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
install -Dm 755 'dptfxtract-static' "${pkgdir}/usr/bin/dptfxtract"
install -Dm 644 'COPYING' "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}