summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--LICENSE67
-rw-r--r--PKGBUILD28
-rw-r--r--drjava-svetovid.desktop9
-rw-r--r--drjava-svetovid.sh3
6 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0576f58a77cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = drjava-svetovid
+ pkgdesc = A lightweight development environment for writing Java programs including Svetovid
+ pkgver = 20140826
+ pkgrel = 1
+ url = https://svetovid.org/lib/drjava.html
+ arch = any
+ license = BSD
+ depends = bash
+ depends = java-environment
+ source = https://svetovid.org/lib/drjava-with-svetovid-lib.jar
+ source = drjava-svetovid.sh
+ source = drjava-svetovid.desktop
+ source = LICENSE
+ sha512sums = f8be92a41159ccb4417726f6b4896628927cd9e51fda54335b5006bf8d921081ab9fd09c1677e0e870e048471778012059326b749f3b0318c3d46b8fd504a39a
+ sha512sums = 619e77fbb1970f68c4de5f0d2d719220f9fb5c0fd15ec746b1c1b181bc757ffe466d09d6deb394c806bb4cc82f091d3e21950e7f82bb8ff9c2a69073d5537663
+ sha512sums = 553614cf30355c09cce2f5d4892486c0687336a1077c5df45ad476fcd6bbb0c98fc0932ebd7699fa236f826c7503d719b0bdd7cd37a4358002573096cee0cfeb
+ sha512sums = 8beb6de3b073857d0eba23c28fcfa7bee669b6caaf8eeb5022f9a78c48d2c8c726bd2448993edcdd8db8e56b3e816d64e21fdfaf392e0440122db67446fada8f
+
+pkgname = drjava-svetovid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2e534989464f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+drjava-with-svetovid-lib.jar
+src
+pkg
+*.tar.zst
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..58729b4e65da
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,67 @@
+DrJava is released under a standard BSD open-source license. The full text
+follows.
+
+ Copyright (c) 2001-2008, JavaPLT group at Rice University
+(drjava@rice.edu) All rights reserved.
+
+ Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+ * Redistributions of source code must retain the above copyright
+notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above
+copyright notice, this list of conditions and the following disclaimer in
+the documentation and/or other materials provided with the distribution.
+ * Neither the names of DrJava, the JavaPLT group, Rice University,
+nor the names of its contributors may be used to endorse or promote
+products derived from this software without specific prior written
+permission.
+
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+ This software is Open Source Initiative approved Open Source Software.
+Open Source Initative Approved is a trademark of the Open Source
+Initiative.
+
+ Download the current version of this project from
+http://www.drjava.org/ or http://sourceforge.net/projects/drjava/
+
+DrJava incorporates and extends DynamicJava (originally available at
+http://koala.ilog.fr/djava), which is licensed under these terms:
+
+ DynamicJava - Copyright (c) 1999 Dyade
+
+ Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to permit
+persons to whom the Software is furnished to do so, subject to the
+following conditions:
+
+ The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN
+NO EVENT SHALL DYADE BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF
+OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE
+
+ Except as contained in this notice, the name of Dyade shall not be
+used in advertising or otherwise to promote the sale, use or other
+dealings in this Software without prior written authorization from Dyade.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5803fbea9cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dušan Simić <dusan.simic1810@gmail.com>
+
+pkgname=drjava-svetovid
+pkgver=20140826
+pkgrel=1
+pkgdesc="A lightweight development environment for writing Java programs including Svetovid"
+arch=('any')
+url="https://svetovid.org/lib/drjava.html"
+license=('BSD')
+depends=('bash' 'java-environment')
+source=('https://svetovid.org/lib/drjava-with-svetovid-lib.jar'
+ 'drjava-svetovid.sh'
+ 'drjava-svetovid.desktop'
+ 'LICENSE')
+sha512sums=('f8be92a41159ccb4417726f6b4896628927cd9e51fda54335b5006bf8d921081ab9fd09c1677e0e870e048471778012059326b749f3b0318c3d46b8fd504a39a'
+ '619e77fbb1970f68c4de5f0d2d719220f9fb5c0fd15ec746b1c1b181bc757ffe466d09d6deb394c806bb4cc82f091d3e21950e7f82bb8ff9c2a69073d5537663'
+ '553614cf30355c09cce2f5d4892486c0687336a1077c5df45ad476fcd6bbb0c98fc0932ebd7699fa236f826c7503d719b0bdd7cd37a4358002573096cee0cfeb'
+ '8beb6de3b073857d0eba23c28fcfa7bee669b6caaf8eeb5022f9a78c48d2c8c726bd2448993edcdd8db8e56b3e816d64e21fdfaf392e0440122db67446fada8f')
+
+package() {
+ cd ${srcdir}
+
+ install -Dm644 drjava-with-svetovid-lib.jar ${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar
+ install -Dm755 drjava-svetovid.sh ${pkgdir}/usr/bin/${pkgname}
+ install -Dm644 LICENSE ${pkgdir}/usr/share/license/${pkgname}/LICENSE
+ install -Dm644 edu/rice/cs/drjava/ui/icons/drjava64.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
+ install -Dm644 drjava-svetovid.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}
diff --git a/drjava-svetovid.desktop b/drjava-svetovid.desktop
new file mode 100644
index 000000000000..1cbfd039d7ce
--- /dev/null
+++ b/drjava-svetovid.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=DrJava with Svetovid
+Comment=Lightweight development environment for writing Java programs with Svetovid
+Exec=drjava-svetovid
+Icon=drjava-svetovid
+Terminal=false
+Categories=Development;Education;Java;
diff --git a/drjava-svetovid.sh b/drjava-svetovid.sh
new file mode 100644
index 000000000000..3098445e08c2
--- /dev/null
+++ b/drjava-svetovid.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+"$JAVA_HOME/bin/java" -jar '/usr/share/java/drjava-svetovid/drjava-svetovid.jar'