summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD18
-rw-r--r--drun-gtk3.install11
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e677f21c39ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = drun-gtk3
+ pkgdesc = A GTK3 run dialog
+ pkgver = 1.0.3.a
+ pkgrel = 1
+ url = https://github.com/loserMcloser/drun-gtk3
+ install = drun-gtk3.install
+ arch = any
+ license = GPL
+ depends = ruby-gtk3
+ depends = ruby-native-package-installer
+ depends = ruby-cairo-gobject
+ provides = drun
+ conflicts = drun
+ source = https://github.com/loserMcloser/drun-gtk3/archive/v1.0.3.a.tar.gz
+ sha256sums = d97abee8e1a9dc0abce1b01136c3341c079e5570415837988ed65c29b5d347b2
+
+pkgname = drun-gtk3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fc8d88e3007
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: loserMcloser <reebydobalina@gmail.com>
+pkgname=drun-gtk3
+pkgver=1.0.3.a
+pkgrel=1
+pkgdesc="A GTK3 run dialog"
+arch=('any')
+provides=('drun')
+conflicts=('drun')
+url="https://github.com/loserMcloser/drun-gtk3"
+license=('GPL')
+depends=('ruby-gtk3' 'ruby-native-package-installer' 'ruby-cairo-gobject')
+install="drun-gtk3.install"
+source=(https://github.com/loserMcloser/${pkgname}/archive/v${pkgver}.tar.gz)
+sha256sums=('d97abee8e1a9dc0abce1b01136c3341c079e5570415837988ed65c29b5d347b2')
+
+package() {
+ install -D -m755 "${srcdir}/${pkgname}-${pkgver}/drun.rb" "${pkgdir}/usr/bin/drun"
+}
diff --git a/drun-gtk3.install b/drun-gtk3.install
new file mode 100644
index 000000000000..d8571f5b9305
--- /dev/null
+++ b/drun-gtk3.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo " If you are migrating to drun-gtk3 from old drun package,"
+ echo " the config and history locations have changed:"
+ echo " . Config moved from ~/.drunrc -> .config/drun/rc"
+ echo " . History moved ~/.drun-history -> .cache/drun/history"
+ echo
+ echo " On Wayland the DIALOG window hint seems to be ignored."
+ echo " On sway you can fix this with"
+ echo " for_window [app_id=\"drun\"] floating enable"
+ echo " in your config."
+}