summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD71
2 files changed, 24 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2fe729c3422..45cb50cc99bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Jul 1 21:43:35 UTC 2016
pkgbase = dukto
pkgdesc = A simple, fast and multi-platform file transfer tool for LAN users.
- pkgver = R6+r111
+ pkgver = R6
pkgrel = 1
- url = http://sourceforge.net/projects/dukto
- arch = any
- license = GPLv2
+ url = https://sourceforge.net/projects/dukto
+ arch = i686
+ arch = x86_64
+ license = GPL2
makedepends = subversion
- depends = qt5-quick1
- depends = qt5-script
- depends = qt5-xmlpatterns
- source = dukto::svn+http://svn.code.sf.net/p/dukto/code/trunk
+ depends = qt4
+ source = dukto::svn+http://svn.code.sf.net/p/dukto/code/trunk#revision=109
sha256sums = SKIP
pkgname = dukto
diff --git a/PKGBUILD b/PKGBUILD
index a5660dc99405..3e4fabc57b26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,25 @@
-# Maintainer: jfperini <@jfperini>
+# Maintainer: spider-mario <spidermario@free.fr>
# Contributor: jfperini <@jfperini>
-
pkgname=dukto
-pkgver=R6+r111
+pkgver=R6
pkgrel=1
pkgdesc="A simple, fast and multi-platform file transfer tool for LAN users."
-arch=('any')
-url="http://sourceforge.net/projects/dukto"
-license=('GPLv2')
-depends=('qt5-quick1' 'qt5-script' 'qt5-xmlpatterns')
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/dukto"
+license=('GPL2')
+depends=('qt4')
makedepends=('subversion')
-# conflicts=('')
-source=("$pkgname"::'svn+http://svn.code.sf.net/p/dukto/code/trunk')
+source=(dukto::'svn+http://svn.code.sf.net/p/dukto/code/trunk#revision=109')
sha256sums=('SKIP')
-pkgver() {
-
- cd "$srcdir/$pkgname"
-
- local ver="$(svnversion)"
- printf "R6+r%s" "${ver//[[:alpha:]]}"
-
+build() {
+ cd dukto
+ qmake-qt4
+ make
}
-build()
-{
-
- cd "$srcdir/$pkgname"
-
- msg2 " -> Build program..."
- qmake-qt4 $pkgname.pro
- make
-
+package() {
+ cd dukto
+ install -Dm755 dukto "$pkgdir/usr/bin/dukto"
+ make INSTALL_ROOT="$pkgdir" install_desktop install_icon
}
-
-package (){
-
- cd "$srcdir/$pkgname"
-
- msg2 " -> Installing program..."
- install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
-
- msg2 " -> Installing icons..."
- install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
-
- msg2 " -> Installing .desktop file..."
- echo "[Desktop Entry]
- Version=1.0
- Encoding=UTF-8
- Type=Application
- Name=Dukto
- GenericName=Transfer files across the LAN
- Comment=Transfer files across the LAN
- Exec=$pkgname
- Icon=$pkgname.png
- StartupNotify=true
- Terminal=false
- Categories=Network;Application;" | tee "$pkgname.desktop"
- echo -e "...Ok.\n"
-
- install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
-
-}
-
-# vim: ts=2 sw=2 et: