summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..236711e95588
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dumptorrent
+ pkgdesc = non-interactive text mode program which displays BitTorrent .torrent file information
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://sourceforge.net/projects/dumptorrent/
+ arch = i686
+ arch = x86_64
+ license = GPL-2
+ depends = glibc
+ source = http://downloads.sourceforge.net/dumptorrent/dumptorrent-1.2.tar.gz
+ md5sums = 90c68a0889bd0eae2ed3392bd5e1fb03
+
+pkgname = dumptorrent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6009a0626c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=dumptorrent
+pkgver=1.2
+pkgrel=1
+pkgdesc="non-interactive text mode program which displays BitTorrent .torrent file information"
+url="https://sourceforge.net/projects/dumptorrent/"
+license=("GPL-2")
+arch=('i686' 'x86_64')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-1.2.tar.gz")
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ install -Dm755 dumptorrent ${pkgdir}/usr/bin/dumptorrent
+ install -Dm755 scrapec ${pkgdir}/usr/bin/scrapec
+}
+md5sums=('90c68a0889bd0eae2ed3392bd5e1fb03')