summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
-rw-r--r--dvbcut-0.6.1-unistd.patch10
-rw-r--r--dvbcut.install11
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3252b984e1e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dvbcut
+ pkgdesc = Qt3 application for cutting parts out of DVB streams
+ pkgver = 0.6.1
+ pkgrel = 2
+ url = http://dvbcut.sourceforge.net/
+ install = dvbcut.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = desktop-file-utils
+ depends = qt3
+ depends = libao
+ depends = libmad
+ depends = a52dec
+ optdepends = mplayer: for video playback inside of DVBCUT
+ source = http://www.mr511.de/dvbcut/dvbcut-0.6.1.tar.gz
+ source = dvbcut-0.6.1-unistd.patch
+ sha256sums = 053941abfd4cf8cfe0c86c78a1c22c9a6bf218cd9ae5158f8ec9181d7996ab2c
+ sha256sums = 8a7640e985efdc05920f59ce84c4639efbe8fafede4ab339178a8ea1f2d6bf62
+
+pkgname = dvbcut
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b0b098d6009
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: sp42b <sp42b|a_t|gmx.net>
+# Contributor: AndyRTR <andreas.radke@freenet.de>
+
+pkgname=dvbcut
+pkgver=0.6.1
+pkgrel=2
+pkgdesc='Qt3 application for cutting parts out of DVB streams'
+arch=('i686' 'x86_64')
+url='http://dvbcut.sourceforge.net/'
+license=('GPL')
+depends=('desktop-file-utils' 'qt3' 'libao' 'libmad' 'a52dec')
+optdepends=('mplayer: for video playback inside of DVBCUT')
+install="$pkgname.install"
+source=("http://www.mr511.de/dvbcut/$pkgname-$pkgver.tar.gz"
+ 'dvbcut-0.6.1-unistd.patch')
+sha256sums=('053941abfd4cf8cfe0c86c78a1c22c9a6bf218cd9ae5158f8ec9181d7996ab2c'
+ '8a7640e985efdc05920f59ce84c4639efbe8fafede4ab339178a8ea1f2d6bf62')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg "Patching..."
+ for i in $srcdir/*.patch; do
+ patch -Np1 -i "$i"
+ done
+
+ ./configure --prefix=/usr --with-qt3-include=/usr/include/qt3/
+ make -j1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 bin/dvbcut "$pkgdir/usr/bin/dvbcut"
+ install -Dm644 dvbcut.1 "$pkgdir/usr/share/man/man1/dvbcut.1"
+ install -Dm644 dvbcut.desktop "$pkgdir/usr/share/applications/dvbcut.desktop"
+ install -Dm644 dvbcut.svg "$pkgdir/usr/share/dvbcut/icons/dvbcut.svg"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/dvbcut-0.6.1-unistd.patch b/dvbcut-0.6.1-unistd.patch
new file mode 100644
index 000000000000..832c11d5252d
--- /dev/null
+++ b/dvbcut-0.6.1-unistd.patch
@@ -0,0 +1,10 @@
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -25,6 +25,7 @@
+ #include <clocale>
+ #include <string>
+ #include <list>
++#include <unistd.h>
+
+ #ifdef HAVE_LIB_AO
+ #include <ao/ao.h>
diff --git a/dvbcut.install b/dvbcut.install
new file mode 100644
index 000000000000..25fdc2b1a8cc
--- /dev/null
+++ b/dvbcut.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}