summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13c2af997cc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dwl-guile-git
+ pkgdesc = Dynamic tiling Wayland compositor configurable in Guile Scheme, based on dwl and libguile - now with a REPL!
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/engstrand-config/dwl-guile
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ makedepends = wayland-protocols
+ depends = wlroots>=0.16
+ optdepends = xorg-xwayland: for XWayland support
+ source = git+https://github.com/engstrand-config/dwl-guile
+ sha256sums = SKIP
+
+pkgname = dwl-guile-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f25408e2c13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Arian-D
+pkgname=dwl-guile-git
+pkgdesc="Dynamic tiling Wayland compositor configurable in Guile Scheme, based on dwl and libguile - now with a REPL!"
+pkgver=2.0.1
+pkgrel=1
+arch=("x86_64" "aarch64")
+url="https://github.com/engstrand-config/dwl-guile"
+license=('GPL')
+depends=('wlroots>=0.16')
+makedepends=('wayland-protocols')
+optdepends=('xorg-xwayland: for XWayland support')
+source=("git+https://github.com/engstrand-config/dwl-guile")
+sha256sums=('SKIP')
+
+build() {
+ # Uncomment to compile with XWayland support
+ # sed -i -e '/-DXWAYLAND/s/^#//' config.mk
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make PREFIX="$pkgdir/usr/" install
+} \ No newline at end of file