summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51da7d2b636d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dwm-polybar-git
+ pkgdesc = Polybar script in Go without recompiling entire polybar
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/Andrmist/dwm-polybar
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go-pie
+ makedepends = git
+ source = dwm-polybar-git::git+https://github.com/Andrmist/dwm-polybar
+ sha512sums = SKIP
+
+pkgname = dwm-polybar-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4bfb92da235
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andriy Cherniy <qugalet@m0e.space>
+
+pkgname=dwm-polybar-git
+pkgdesc='Polybar script in Go without recompiling entire polybar '
+pkgver=0.r6
+pkgrel=1
+url='https://github.com/Andrmist/dwm-polybar'
+license=(MIT)
+arch=(x86_64 i686)
+makedepends=(go-pie git)
+source=("${pkgname}::git+${url}")
+sha512sums=(SKIP)
+
+pkgver () {
+ cd "${pkgname}"
+ echo "0.r$(git rev-list --count HEAD)"
+}
+
+build () {
+ cd "${pkgname}"
+ local curdir=$(pwd)
+ go build -v \
+ -gcflags "all=-trimpath=${curdir}" \
+ -asmflags "all=-trimpath=${curdir}" \
+ -ldflags "-extldflags '${LDFLAGS}'" \
+ .
+}
+
+package () {
+ cd "${pkgname}"
+ install -Dm755 dwm-polybar "${pkgdir}/usr/bin/dwm-polybar"
+}