summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a97ae880a179
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dwmstatus-git
+ pkgdesc = A simple dwm status application in C
+ pkgver = r4.51bc02f
+ pkgrel = 1
+ url = https://git.suckless.org/dwmstatus
+ arch = x86_64
+ license = MIT
+ depends = libx11
+ provides = dwmstatus
+ conflicts = dwmstatus
+ source = git+https://git.suckless.org/dwmstatus
+ sha256sums = SKIP
+
+pkgname = dwmstatus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d574815fe86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Viachaslau Khalikin <khalikin'at'yandex>
+
+_pkgbase=dwmstatus
+pkgname=dwmstatus-git
+pkgver=r4.51bc02f
+pkgrel=1
+pkgdesc="A simple dwm status application in C"
+arch=('x86_64')
+url="https://git.suckless.org/dwmstatus"
+license=('MIT')
+provides=("$_pkgbase")
+conflicts=("$_pkgbase")
+depends=('libx11')
+source=("git+https://git.suckless.org/dwmstatus")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgbase"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd $_pkgbase
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 PREFIX=/usr DESTDIR="$pkgdir" install
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ft=sh ts=2 sw=2 et: