summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--dyndnsc.service1
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5f391856443..19d28b7027d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = dyndnsc
pkgdesc = Dynamic DNS client with support for multiple protocols and services. Compatible with IPv6 dual stack.
- pkgver = 0.6.0
- pkgrel = 3
+ pkgver = 0.6.1
+ pkgrel = 1
url = https://pypi.org/project/dyndnsc
arch = any
license = MIT
makedepends = python-pip
makedepends = python-wheel
+ makedepends = python-setuptools
depends = python-requests
- depends = python-setuptools
depends = python-netifaces
depends = python-dnspython
depends = python-daemonocle
depends = python-json-logging
- source = https://github.com/infothrill/python-dyndnsc/archive/0.6.0.zip
+ source = https://github.com/infothrill/python-dyndnsc/archive/0.6.1.zip
source = dyndnsc.service
- sha256sums = ff0fcd735e96a958fdce51910d962f064c0da6b4b9723e929c1a1e5de2570df0
- sha256sums = 7ac42ed7d22517d45cc44195d2abcb0c0ba67c257453cda8e83d896b7a95cd76
+ sha256sums = b85a1dd2c9d43c0573ff98421a0cdec8229edbd6ca9d973fa8281b6b7a5c9920
+ sha256sums = 6af0da619924475f346400a943645875a175d97998d065b904eb9330168da6ea
pkgname = dyndnsc
diff --git a/PKGBUILD b/PKGBUILD
index c4a51d8fbdf6..023896c8792f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@
pkgname=dyndnsc
_pkgname=python-dyndnsc
-pkgver=0.6.0
-pkgrel=3
+pkgver=0.6.1
+pkgrel=1
pkgdesc="Dynamic DNS client with support for multiple protocols and services. Compatible with IPv6 dual stack."
arch=('any')
url="https://pypi.org/project/dyndnsc"
license=('MIT')
-depends=('python-requests' 'python-setuptools' 'python-netifaces' 'python-dnspython' 'python-daemonocle' 'python-json-logging')
-makedepends=('python-pip' 'python-wheel')
+depends=('python-requests' 'python-netifaces' 'python-dnspython' 'python-daemonocle' 'python-json-logging')
+makedepends=('python-pip' 'python-wheel' 'python-setuptools')
source=("https://github.com/infothrill/$_pkgname/archive/$pkgver.zip"
'dyndnsc.service')
-sha256sums=('ff0fcd735e96a958fdce51910d962f064c0da6b4b9723e929c1a1e5de2570df0'
- '7ac42ed7d22517d45cc44195d2abcb0c0ba67c257453cda8e83d896b7a95cd76')
+sha256sums=('b85a1dd2c9d43c0573ff98421a0cdec8229edbd6ca9d973fa8281b6b7a5c9920'
+ '6af0da619924475f346400a943645875a175d97998d065b904eb9330168da6ea')
build() {
cd "$_pkgname-$pkgver"
diff --git a/dyndnsc.service b/dyndnsc.service
index d510e768ce12..af5a06b7c5db 100644
--- a/dyndnsc.service
+++ b/dyndnsc.service
@@ -1,6 +1,7 @@
[Unit]
Description=dyndnsc
After=network-online.target
+Requires=network-online.target
[Service]
ExecStart=/usr/bin/dyndnsc --loop --config /etc/dyndnsc.conf