summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO23
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
-rwxr-xr-xeasea.install12
-rwxr-xr-xeasea.sh3
5 files changed, 103 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..b1d1c04119e0
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,23 @@
+pkgbase = easea
+ pkgdesc = EASEA (EAsy Specification of Evolutionary Algorithms) is an Artificial Evolution platform that allows with only basic skills in computer science to implement evolutionary algorithms and to exploit the massive parallelism of many-core architecture
+ pkgver = 1.0.3
+ pkgrel = 2
+ url = http://easea.unistra.fr/
+ install = easea.install
+ arch = x86_64
+ arch = i686
+ license = AGPL3
+ makedepends = gcc>4.4,
+ makedepends = cuda>4.1,
+ makedepends = make>3,
+ makedepends = texlive-bin
+ depends = gcc-libs
+ depends = perl
+ depends = bash
+ depends = java-environment
+ source = http://optimate.dl.sourceforge.net/project/easea/EASEA%20for%20UNIX/1.0.3/easea-1.0.3.tar.gz
+ source = easea.sh
+ options = staticlibs
+
+pkgname = easea
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08965dc35559
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = easea
+ pkgdesc = EASEA (EAsy Specification of Evolutionary Algorithms) is an Artificial Evolution platform that allows with only basic skills in computer science to implement evolutionary algorithms and to exploit the massive parallelism of many-core architecture
+ pkgver = 1.0.3
+ pkgrel = 2
+ url = http://easea.unistra.fr/
+ install = easea.install
+ arch = x86_64
+ arch = i686
+ license = AGPL3
+ makedepends = gcc>4.4,
+ makedepends = cuda>4.1,
+ makedepends = make>3,
+ makedepends = texlive-bin
+ depends = gcc-libs
+ depends = perl
+ depends = bash
+ depends = java-environment
+ options = staticlibs
+ source = http://optimate.dl.sourceforge.net/project/easea/EASEA%20for%20UNIX/1.0.3/easea-1.0.3.tar.gz
+ source = easea.sh
+ md5sums = 4241a503b277e753c0175b13ff525767
+ md5sums = 58501918cbb27ddc97d806091f2d4b1d
+
+pkgname = easea
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2450e67bbb66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Zeph <zeph33@gmail.com>
+
+pkgname=easea
+pkgver=1.0.3
+pkgrel=2
+pkgdesc="EASEA (EAsy Specification of Evolutionary Algorithms) is an Artificial Evolution platform that allows with only basic skills in computer science to implement evolutionary algorithms and to exploit the massive parallelism of many-core architecture"
+arch=('x86_64' 'i686')
+url="http://easea.unistra.fr/"
+license=('AGPL3')
+install=easea.install
+depends=('gcc-libs' 'perl' 'bash' 'java-environment')
+makedepends=('gcc>4.4', 'cuda>4.1', 'make>3', 'texlive-bin')
+options=('staticlibs')
+
+source=('http://optimate.dl.sourceforge.net/project/easea/EASEA%20for%20UNIX/1.0.3/easea-1.0.3.tar.gz' 'easea.sh')
+md5sums=('4241a503b277e753c0175b13ff525767' '58501918cbb27ddc97d806091f2d4b1d')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+ cd "$srcdir/$pkgname-$pkgver/doc"
+ pdflatex easea_manual.tex
+}
+
+package() {
+ cd "$pkgdir"
+ mkdir -p opt/easea/ opt/easea/bin opt/easea/tpl opt/easea/libeasea/include opt/easea/boost opt/easea/easeagrapher/ opt/easea/samples opt/easea/doc
+ cd "$srcdir/$pkgname-$pkgver"
+ cp bin/easea $pkgdir/opt/easea/bin/
+ cp tpl/* $pkgdir/opt/easea/tpl/
+ cp libeasea/include/* $pkgdir/opt/easea/libeasea/include/
+ cp libeasea/libeasea.a $pkgdir/opt/easea/libeasea/
+ cp boost/program_options.a $pkgdir/opt/easea/boost
+ cp -r boost/boost/ $pkgdir/opt/easea/boost/boost/
+ cp easeagrapher/EaseaGrapher.jar $pkgdir/opt/easea/easeagrapher/
+ cp -r examples/* $pkgdir/opt/easea/samples/
+ cp doc/easea_manual.pdf $pkgdir/opt/easea/doc/easea_manual.pdf
+ install -Dm755 "${srcdir}/easea.sh" "${pkgdir}/etc/profile.d/easea.sh"
+}
+
diff --git a/easea.install b/easea.install
new file mode 100755
index 000000000000..ac0c71c718d4
--- /dev/null
+++ b/easea.install
@@ -0,0 +1,12 @@
+#!/bin/sh
+post_install() {
+ echo "The EASEA binaries are in /opt/easea/bin"
+ echo "The EASEA samples are in /opt/easea/samples"
+ echo "The EASEA docs are in /opt/easea/doc/easea_manual.pdf"
+ echo "You need to relogin in order for the EASEA binaries to appear in your PATH"
+ post_upgrade
+}
+
+post_upgrade() {
+ ldconfig -r .
+} \ No newline at end of file
diff --git a/easea.sh b/easea.sh
new file mode 100755
index 000000000000..52c6fe62bdae
--- /dev/null
+++ b/easea.sh
@@ -0,0 +1,3 @@
+# EASEA paths for compiler and library
+export EZ_PATH="/opt/easea/"
+export PATH="$PATH:/opt/easea/bin" \ No newline at end of file