summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b6da22c6930..6656f0649925 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ecal
pkgdesc = enhanced Communication Abstraction Layer
pkgver = 5.8.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/continental/ecal
arch = x86_64
arch = armv7h
@@ -17,7 +17,11 @@ pkgbase = ecal
backup = etc/ecal/ecal.ini
backup = etc/ecal/ecaltime.ini
source = git+https://github.com/continental/ecal.git
+ source = Support_GCC_11.patch
+ source = Support_Protobuf_3_15_6.patch
sha256sums = SKIP
+ sha256sums = 794f88435e6251b25664f9b1eda0928394d8265983eadc3dbc9106d316a7895f
+ sha256sums = 6346bafc67654da0714a93c72e09530959fd7fc83716ba5d7a638dbd82d75b38
pkgname = ecal
diff --git a/PKGBUILD b/PKGBUILD
index 7013a9416293..081a7c33386b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ecal
pkgver=5.8.8
-pkgrel=1
+pkgrel=2
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64' 'armv7h')
url="https://github.com/continental/ecal"
@@ -10,8 +10,12 @@ license=('Apache')
depends=('curl' 'protobuf' 'qt5-base' 'hdf5')
makedepends=('cmake' 'doxygen' 'git' 'graphviz')
optdepends=()
-source=(git+https://github.com/continental/ecal.git)
-sha256sums=('SKIP')
+source=('git+https://github.com/continental/ecal.git'
+ 'Support_GCC_11.patch'
+ 'Support_Protobuf_3_15_6.patch')
+sha256sums=('SKIP'
+ '794f88435e6251b25664f9b1eda0928394d8265983eadc3dbc9106d316a7895f'
+ '6346bafc67654da0714a93c72e09530959fd7fc83716ba5d7a638dbd82d75b38')
backup=('etc/ecal/ecal.ini' 'etc/ecal/ecaltime.ini')
prepare() {
@@ -19,8 +23,8 @@ prepare() {
git checkout v"${pkgver}"
git submodule init
git submodule update
- patch --forward --strip=1 --input="../../Support_GCC_11.patch"
- patch --forward --strip=1 --input="../../Support_Protobuf_3_15_6.patch"
+ patch --forward --strip=1 --input="../Support_GCC_11.patch"
+ patch --forward --strip=1 --input="../Support_Protobuf_3_15_6.patch"
}
build() {