summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--Support_GCC_11.patch32
-rw-r--r--Support_Protobuf_3_15_6.patch17
4 files changed, 6 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5cbbc966dd5..ba467caecd1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ecal
pkgdesc = enhanced Communication Abstraction Layer
- pkgver = 5.8.9
+ pkgver = 5.9.0
pkgrel = 1
url = https://github.com/continental/ecal
arch = x86_64
@@ -17,11 +17,6 @@ pkgbase = ecal
backup = etc/ecal/ecal.ini
backup = etc/ecal/ecaltime.ini
source = git+https://github.com/continental/ecal.git
- source = Support_GCC_11.patch
- source = Support_Protobuf_3_15_6.patch
sha256sums = SKIP
- sha256sums = 794f88435e6251b25664f9b1eda0928394d8265983eadc3dbc9106d316a7895f
- sha256sums = 6346bafc67654da0714a93c72e09530959fd7fc83716ba5d7a638dbd82d75b38
pkgname = ecal
-
diff --git a/PKGBUILD b/PKGBUILD
index e622a98c59c2..d47e8793acc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Borgert <tobias.borgert@gmail.com>
pkgname=ecal
-pkgver=5.8.9
+pkgver=5.9.0
pkgrel=1
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64' 'armv7h')
@@ -10,12 +10,8 @@ license=('Apache')
depends=('curl' 'protobuf' 'qt5-base' 'hdf5')
makedepends=('cmake' 'doxygen' 'git' 'graphviz')
optdepends=()
-source=('git+https://github.com/continental/ecal.git'
- 'Support_GCC_11.patch'
- 'Support_Protobuf_3_15_6.patch')
-sha256sums=('SKIP'
- '794f88435e6251b25664f9b1eda0928394d8265983eadc3dbc9106d316a7895f'
- '6346bafc67654da0714a93c72e09530959fd7fc83716ba5d7a638dbd82d75b38')
+source=('git+https://github.com/continental/ecal.git')
+sha256sums=('SKIP')
backup=('etc/ecal/ecal.ini' 'etc/ecal/ecaltime.ini')
prepare() {
@@ -23,8 +19,8 @@ prepare() {
git checkout v"${pkgver}"
git submodule init
git submodule update
- patch --forward --strip=1 --input="../Support_GCC_11.patch"
- patch --forward --strip=1 --input="../Support_Protobuf_3_15_6.patch"
+ #patch --forward --strip=1 --input="../Support_GCC_11.patch"
+ #patch --forward --strip=1 --input="../Support_Protobuf_3_15_6.patch"
}
build() {
diff --git a/Support_GCC_11.patch b/Support_GCC_11.patch
deleted file mode 100644
index 8441fb2585ee..000000000000
--- a/Support_GCC_11.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Index: samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp
-IDEA additional info:
-Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
-<+>UTF-8
-===================================================================
-diff --git a/samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp b/samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp
---- a/samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp (revision b160392e47800319a498b2ff30c85cb418bb794c)
-+++ b/samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp (date 1621537793427)
-@@ -25,6 +25,7 @@
- #include <atomic>
- #include <chrono>
- #include <thread>
-+#include <memory>
-
- #define PAYLOAD_SIZE 1024
- #define PRINT_LOG 0
-Index: app/rec/rec_addon_core/src/time_limited_queue.h
-IDEA additional info:
-Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
-<+>UTF-8
-===================================================================
-diff --git a/app/rec/rec_addon_core/src/time_limited_queue.h b/app/rec/rec_addon_core/src/time_limited_queue.h
---- a/app/rec/rec_addon_core/src/time_limited_queue.h (revision b160392e47800319a498b2ff30c85cb418bb794c)
-+++ b/app/rec/rec_addon_core/src/time_limited_queue.h (date 1621537489591)
-@@ -25,6 +25,7 @@
- #include <chrono>
- #include <thread>
- #include <functional>
-+#include <condition_variable>
-
- template <class T>
- class TimeLimtedQueue : public std::enable_shared_from_this<TimeLimtedQueue<T>>
diff --git a/Support_Protobuf_3_15_6.patch b/Support_Protobuf_3_15_6.patch
deleted file mode 100644
index 2b2295f361eb..000000000000
--- a/Support_Protobuf_3_15_6.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp
-IDEA additional info:
-Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
-<+>UTF-8
-===================================================================
-diff --git a/ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp b/ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp
---- a/ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp (revision b160392e47800319a498b2ff30c85cb418bb794c)
-+++ b/ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp (date 1621537593314)
-@@ -160,7 +160,7 @@
- binary_input.assign((char*)data_->buf, static_cast<size_t>(data_->size));
- msg_ptr.clear();
- auto status = google::protobuf::util::BinaryToJsonString(resolver_.get(), topic_type_full, binary_input, &msg_ptr, options);
-- if (status == google::protobuf::util::Status::OK)
-+ if (status.ok())
- {
- SReceiveCallbackData cb_data;
- cb_data.buf = (void*)msg_ptr.c_str();