summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
-rw-r--r--ecal-v5.3.2-archlinux-fabs.patch54
3 files changed, 15 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65492a671ff5..b32d5a2633eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = ecal
pkgdesc = enhanced Communication Abstraction Layer
- pkgver = 5.3.4.3
+ pkgver = 5.3.4.4
pkgrel = 1
url = https://github.com/continental/ecal
arch = x86_64
+ arch = armhf
license = Apache
makedepends = asio
makedepends = cmake
@@ -13,8 +14,10 @@ pkgbase = ecal
makedepends = tclap
depends = protobuf
depends = qt5-base
- source = https://github.com/continental/ecal/archive/v5.3.4.3.tar.gz
- sha256sums = 89c9e303a63ce4dba576d45464e9e08325f2697fb9717b1174d170b0f0a3e9c7
+ backup = etc/ecal/ecal.ini
+ backup = etc/ecal/ecaltime.ini
+ source = https://github.com/continental/ecal/archive/v5.3.4.4.tar.gz
+ sha256sums = 8036130e84191618e9d6f056101b5c9f70c03fdbd97adbcd2bca741f0ce08fb1
pkgname = ecal
diff --git a/PKGBUILD b/PKGBUILD
index 8e74d59b9476..5188ffbe2fa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Tobias Borgert <tobias.borgert@gmail.com>
pkgname=ecal
-pkgver=5.3.4.3
+pkgver=5.3.4.4
pkgrel=1
pkgdesc="enhanced Communication Abstraction Layer"
-arch=('x86_64')
+arch=('x86_64' 'armhf')
url="https://github.com/continental/ecal"
license=('Apache')
depends=('protobuf' 'qt5-base')
makedepends=('asio' 'cmake' 'doxygen' 'graphviz' 'simpleini' 'tclap')
optdepends=()
source=(https://github.com/continental/ecal/archive/v$pkgver.tar.gz)
-sha256sums=('89c9e303a63ce4dba576d45464e9e08325f2697fb9717b1174d170b0f0a3e9c7')
+sha256sums=('8036130e84191618e9d6f056101b5c9f70c03fdbd97adbcd2bca741f0ce08fb1')
+backup=('etc/ecal/ecal.ini' 'etc/ecal/ecaltime.ini')
build() {
cd $pkgname-$pkgver
@@ -30,8 +31,10 @@ package() {
cd $pkgname-$pkgver
cd _build
DESTDIR="$pkgdir" make install
- mv "$pkgdir/usr/lib/cmake/"* "$pkgdir/usr/lib64/cmake/"
- rm -r "$pkgdir/usr/lib"
- mv "$pkgdir/usr/lib64/" "$pkgdir/usr/lib"
+ if [ -d "$pkgdir/usr/lib64/" ]; then
+ mv "$pkgdir/usr/lib/cmake/"* "$pkgdir/usr/lib64/cmake/"
+ rm -r "$pkgdir/usr/lib"
+ mv "$pkgdir/usr/lib64/" "$pkgdir/usr/lib"
+ fi
mv "$pkgdir/usr/etc" "$pkgdir/etc"
}
diff --git a/ecal-v5.3.2-archlinux-fabs.patch b/ecal-v5.3.2-archlinux-fabs.patch
deleted file mode 100644
index 140fe39862ac..000000000000
--- a/ecal-v5.3.2-archlinux-fabs.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff --git a/README.md b/README.md
-index 460aaff..d4d2940 100644
---- a/README.md
-+++ b/README.md
-@@ -102,11 +102,14 @@ You need
-
- #### Qt 5
-
--Install Qt5 by starting the installer and selecting `msvc2015 32-bit` and `msvc2015 64-bit` from the latest Qt5 version. Create an environment variable `QT5_ROOT_DIRECTORY` that points to the directory containing the architecture-specific folders. It should look like this:
-+Install Qt5 by starting the installer and selecting `msvc2015 32-bit` and `msvc2015 64-bit` (VS2015) or `msvc2017 32-bit` and `msvc2017 64-bit` (VS2017) from the latest Qt5 version. Create an environment variable `QT5_ROOT_DIRECTORY` that points to the directory containing the architecture-specific folders. It should look like this:
-
- %QT5_ROOT_DIRECTORY%
- ├ msvc2015
-- └ msvc2015_64
-+ ├ msvc2015_64
-+ ├ msvc2017
-+ └ msvc2017_64
-+
-
- #### Build eCAL
-
-@@ -292,7 +295,7 @@ void OnReceive(const char* topic_name_, const std::string& message_)
- }
-
- // create subscriber
--eCAL::eCAL::string::Subscriber<std::string> sub("foo");
-+eCAL::string::CSubscriber<std::string> sub("foo");
-
- // register subscriber callback function
- auto callback = std::bind(OnReceive, std::placeholders::_1, std::placeholders::_2);
-diff --git a/app/mon/eCALMon/src/Widgets/Models/ProcessTreeItem.cpp b/app/mon/eCALMon/src/Widgets/Models/ProcessTreeItem.cpp
-index d59a80f..4e03b2a 100644
---- a/app/mon/eCALMon/src/Widgets/Models/ProcessTreeItem.cpp
-+++ b/app/mon/eCALMon/src/Widgets/Models/ProcessTreeItem.cpp
-@@ -22,6 +22,7 @@
- #include <QColor>
- #include <QFont>
-
-+#include <math.h>
- #include <cfloat>
-
- #include "ItemDataRoles.h"
-diff --git a/samples/cpp/services/math_server/src/math_server.cpp b/samples/cpp/services/math_server/src/math_server.cpp
-index 855deb4..04ae434 100644
---- a/samples/cpp/services/math_server/src/math_server.cpp
-+++ b/samples/cpp/services/math_server/src/math_server.cpp
-@@ -23,6 +23,7 @@
- #include <iostream>
- #include <chrono>
- #include <thread>
-+#include <math.h>
- #include <cfloat>
-
- #include "math.pb.h"