summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD30
-rw-r--r--Support_GCC_11.patch32
-rw-r--r--Support_Protobuf_3_15_6.patch17
4 files changed, 67 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 311ea8c3698a..6b6da22c6930 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ecal
pkgdesc = enhanced Communication Abstraction Layer
- pkgver = 5.8.7
- pkgrel = 2
+ pkgver = 5.8.8
+ pkgrel = 1
url = https://github.com/continental/ecal
arch = x86_64
arch = armv7h
diff --git a/PKGBUILD b/PKGBUILD
index e4c18f128956..7013a9416293 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tobias Borgert <tobias.borgert@gmail.com>
pkgname=ecal
-pkgver=5.8.7
-pkgrel=2
+pkgver=5.8.8
+pkgrel=1
pkgdesc="enhanced Communication Abstraction Layer"
arch=('x86_64' 'armv7h')
url="https://github.com/continental/ecal"
@@ -19,19 +19,21 @@ prepare() {
git checkout v"${pkgver}"
git submodule init
git submodule update
+ patch --forward --strip=1 --input="../../Support_GCC_11.patch"
+ patch --forward --strip=1 --input="../../Support_Protobuf_3_15_6.patch"
}
build() {
- cd "${pkgname}"
- mkdir -p _build
- cd _build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DECAL_THIRDPARTY_BUILD_PROTOBUF=OFF \
- -DECAL_THIRDPARTY_BUILD_CURL=OFF \
- -DECAL_THIRDPARTY_BUILD_HDF5=OFF \
+ cd "${pkgname}"
+ mkdir -p _build
+ cd _build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DECAL_THIRDPARTY_BUILD_PROTOBUF=OFF \
+ -DECAL_THIRDPARTY_BUILD_CURL=OFF \
+ -DECAL_THIRDPARTY_BUILD_HDF5=OFF \
-DCMAKE_INSTALL_SYSCONFDIR=/etc
- make
+ make
}
package() {
@@ -49,7 +51,7 @@ package() {
install -D -m644 "${srcdir}"/"${pkgname}"/licenses/spdlog/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/thirdparty/spdlog/LICENSE
install -D -m644 "${srcdir}"/"${pkgname}"/licenses/tclap/COPYING "${pkgdir}"/usr/share/licenses/"${pkgname}"/thirdparty/tclap/COPYING
install -D -m644 "${srcdir}"/"${pkgname}"/licenses/termcolor/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/thirdparty/termcolor/LICENSE
- cd "${pkgname}"
- cd _build
- DESTDIR="$pkgdir" make install
+ cd "${pkgname}"
+ cd _build
+ DESTDIR="$pkgdir" make install
}
diff --git a/Support_GCC_11.patch b/Support_GCC_11.patch
new file mode 100644
index 000000000000..8441fb2585ee
--- /dev/null
+++ b/Support_GCC_11.patch
@@ -0,0 +1,32 @@
+Index: samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp
+IDEA additional info:
+Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
+<+>UTF-8
+===================================================================
+diff --git a/samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp b/samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp
+--- a/samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp (revision b160392e47800319a498b2ff30c85cb418bb794c)
++++ b/samples/cpp/multiple/multiple_snd/src/multiple_snd.cpp (date 1621537793427)
+@@ -25,6 +25,7 @@
+ #include <atomic>
+ #include <chrono>
+ #include <thread>
++#include <memory>
+
+ #define PAYLOAD_SIZE 1024
+ #define PRINT_LOG 0
+Index: app/rec/rec_addon_core/src/time_limited_queue.h
+IDEA additional info:
+Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
+<+>UTF-8
+===================================================================
+diff --git a/app/rec/rec_addon_core/src/time_limited_queue.h b/app/rec/rec_addon_core/src/time_limited_queue.h
+--- a/app/rec/rec_addon_core/src/time_limited_queue.h (revision b160392e47800319a498b2ff30c85cb418bb794c)
++++ b/app/rec/rec_addon_core/src/time_limited_queue.h (date 1621537489591)
+@@ -25,6 +25,7 @@
+ #include <chrono>
+ #include <thread>
+ #include <functional>
++#include <condition_variable>
+
+ template <class T>
+ class TimeLimtedQueue : public std::enable_shared_from_this<TimeLimtedQueue<T>>
diff --git a/Support_Protobuf_3_15_6.patch b/Support_Protobuf_3_15_6.patch
new file mode 100644
index 000000000000..2b2295f361eb
--- /dev/null
+++ b/Support_Protobuf_3_15_6.patch
@@ -0,0 +1,17 @@
+Index: ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp
+IDEA additional info:
+Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
+<+>UTF-8
+===================================================================
+diff --git a/ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp b/ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp
+--- a/ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp (revision b160392e47800319a498b2ff30c85cb418bb794c)
++++ b/ecal/core/src/pubsub/ecal_proto_dyn_json_sub.cpp (date 1621537593314)
+@@ -160,7 +160,7 @@
+ binary_input.assign((char*)data_->buf, static_cast<size_t>(data_->size));
+ msg_ptr.clear();
+ auto status = google::protobuf::util::BinaryToJsonString(resolver_.get(), topic_type_full, binary_input, &msg_ptr, options);
+- if (status == google::protobuf::util::Status::OK)
++ if (status.ok())
+ {
+ SReceiveCallbackData cb_data;
+ cb_data.buf = (void*)msg_ptr.c_str();