summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD8
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75b7d14a4a1b..db25ff9360b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = eclipse-jboss
pkgdesc = JBoss application server developer tools plugins for Eclipse IDE
- pkgver = 4.17.0.Final
+ pkgver = 4.26.0.Final
pkgrel = 1
url = http://tools.jboss.org/
arch = any
license = LGPL
license = EPL
license = BSD
- depends = eclipse>=4.5.0
+ depends = eclipse-java>=4.5.0
options = !strip
- source = download.zip::http://download.jboss.org/jbosstools/static/photon/stable/updates/core/jbosstools-4.17.0.Final-updatesite-core.zip
- sha256sums = e7110fddf9f9e3825241d9e0014ce951ed5e08250e68b7ddd3593f894443fe2f
+ source = download.zip::http://download.jboss.org/jbosstools/static/photon/stable/updates/core/jbosstools-4.26.0.Final-updatesite-core.zip
+ sha256sums = ed6f51e010391e606412c4388ab9f8883ce08307a17b892cf27c8b54ef2fa244
pkgname = eclipse-jboss
diff --git a/.gitignore b/.gitignore
index 708b7203f13e..92934525fd48 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,4 @@
+/pkg/
+/src/
download.zip
-
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 33c874c7cf5e..e10cc87a99f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
#Maintainer: Raimar Buehmann <raimar _at_ buehmann _dot_ de>
pkgname=eclipse-jboss
-pkgver=4.17.0.Final
+pkgver=4.26.0.Final
_eclipsever=photon
pkgrel=1
pkgdesc='JBoss application server developer tools plugins for Eclipse IDE'
arch=('any')
url='http://tools.jboss.org/'
license=('LGPL' 'EPL' 'BSD')
-depends=('eclipse>=4.5.0')
+depends=('eclipse-java>=4.5.0')
options=('!strip')
source=("download.zip::http://download.jboss.org/jbosstools/static/${_eclipsever}/stable/updates/core/jbosstools-${pkgver}-updatesite-core.zip")
-sha256sums=('e7110fddf9f9e3825241d9e0014ce951ed5e08250e68b7ddd3593f894443fe2f')
+sha256sums=('ed6f51e010391e606412c4388ab9f8883ce08307a17b892cf27c8b54ef2fa244')
package() {
# remove features and plug-ins containing sources
rm features/*.source_*
rm plugins/*.source_*
# remove gz files
- rm plugins/*.pack.gz
+# rm plugins/*.pack.gz
_dest=${pkgdir}/usr/lib/eclipse/dropins/${pkgname/eclipse-}/eclipse
install -d $_dest
# extract features (otherwise features are not recognized)