summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2910fbbf7c72..6743e9186aac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sat Dec 26 04:24:23 UTC 2015
pkgbase = eggwm-qt5
pkgdesc = A simple and light Qt5 WM. 100% compatible with the EWMH and ICCCM standards.
- pkgver = git
+ pkgver = r10.79e245a
pkgrel = 1
- url = https://github.com/xiangzhai/eggwm/
+ url = https://notabug.org/tux_peng/eggwm
arch = i686
arch = x86_64
license = GPL3
@@ -14,7 +12,7 @@ pkgbase = eggwm-qt5
depends = qt5-x11extras
provides = eggwm
conflicts = eggwm
- source = git+https://github.com/xiangzhai/eggwm.git
+ source = git+https://notabug.org/tux_peng/eggwm.git#commit=79e245a8c855df45cfd9356ca56628048ba46d0d
sha256sums = SKIP
pkgname = eggwm-qt5
diff --git a/PKGBUILD b/PKGBUILD
index ef15df0ea92a..0a7c3decd0e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,35 @@
# Contributor: <josh.jpenguin@gmail.com>
_pkgname=eggwm
pkgname=$_pkgname-qt5
-pkgver=git
+pkgver=r10.79e245a
pkgrel=1
pkgdesc="A simple and light Qt5 WM. 100% compatible with the EWMH and ICCCM standards."
-url="https://github.com/xiangzhai/eggwm/"
+url="https://notabug.org/tux_peng/eggwm"
arch=('i686' 'x86_64')
-license=("GPL3")
-depends=("qt5-base" "qt5-x11extras")
-makedepends=("git" "qt5-tools")
+license=('GPL3')
+depends=('qt5-base' 'qt5-x11extras')
+makedepends=('git' 'qt5-tools')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/xiangzhai/$_pkgname.git")
+source=("git+https://notabug.org/tux_peng/eggwm.git#commit=79e245a8c855df45cfd9356ca56628048ba46d0d")
sha256sums=("SKIP")
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
build() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
export QT_SELECT=5
qmake
make
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
find installation -type f | xargs chmod -x
- install -d "$pkgdir/usr/share/eggwm"
- cp -R installation/* "$pkgdir/usr/share/eggwm"
- install -D -m755 eggwm "$pkgdir/usr/bin/eggwm"
+ install -d "$pkgdir"/usr/share/eggwm
+ cp -R installation/* "$pkgdir"/usr/share/eggwm
+ install -D -m755 eggwm "$pkgdir"/usr/bin/eggwm
}