summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d58827f50b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = elles-bin
+ pkgdesc = A nicer /bin/ls
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/arp242/elles
+ arch = x86_64
+ license = MIT
+ provides = elles
+ conflicts = elles
+ source = https://github.com/arp242/elles/releases/download/v0.1.0/elles-v0.1.0-linux-amd64.gz
+ source = https://raw.githubusercontent.com/arp242/elles/master/LICENSE
+ sha256sums = ba0c65c96079f9120dca32fca30a8ebbec0b85bad2933d2938b555868dff35dd
+ sha256sums = 401b054d7378650e9289148ff085496190a301820c93eaacec84f1ae46cb2d22
+
+pkgname = elles-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43aae55864bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Lukas Waymann <io@meribold.org>
+
+pkgname=elles-bin
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A nicer /bin/ls'
+arch=(x86_64)
+url=https://github.com/arp242/elles
+license=(MIT)
+provides=(elles)
+conflicts=(elles)
+
+source=("https://github.com/arp242/elles/releases/download/v$pkgver/elles-v$pkgver-linux-amd64.gz"
+ "https://raw.githubusercontent.com/arp242/elles/master/LICENSE")
+sha256sums=(ba0c65c96079f9120dca32fca30a8ebbec0b85bad2933d2938b555868dff35dd
+ 401b054d7378650e9289148ff085496190a301820c93eaacec84f1ae46cb2d22)
+
+package() {
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D "elles-v$pkgver-linux-amd64" "$pkgdir/usr/bin/elles"
+}