summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--tools.patch28
3 files changed, 11 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b2e49774ab1..5de7212b32f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = eltclsh
pkgdesc = interactive shell for the TCL programming language
- pkgver = 1.16
- pkgrel = 2
+ pkgver = 1.17
+ pkgrel = 1
url = http://homepages.laas.fr/mallet/soft/shell/eltclsh
arch = i686
arch = x86_64
@@ -12,10 +12,8 @@ pkgbase = eltclsh
depends = tcl
depends = tk
depends = libedit
- source = tools.patch
- source = http://distfiles.openrobots.org/eltclsh/eltclsh-1.16.tar.gz
- md5sums = af3e1e0eb06d1cebed7d4c1bdae5ff29
- md5sums = a13130374265b871ff17fdec357aee60
+ source = http://distfiles.openrobots.org/eltclsh/eltclsh-1.17.tar.gz
+ md5sums = e698f5969970feafeff934b1294a37c0
pkgname = eltclsh
diff --git a/PKGBUILD b/PKGBUILD
index cfe19164637a..4774e3403142 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: tequa
pkgname=eltclsh
-pkgver=1.16
-pkgrel=2
+pkgver=1.17
+pkgrel=1
epoch=
pkgdesc="interactive shell for the TCL programming language"
arch=('i686' 'x86_64' 'armv7h')
@@ -20,18 +20,16 @@ options=()
install=
changelog=
source=(
- "tools.patch"
"http://distfiles.openrobots.org/eltclsh/$pkgname-$pkgver.tar.gz"
)
noextract=()
-md5sums=('af3e1e0eb06d1cebed7d4c1bdae5ff29'
- 'a13130374265b871ff17fdec357aee60')
+md5sums=('e698f5969970feafeff934b1294a37c0')
validpgpkeys=()
-prepare() {
- cd "$pkgname-$pkgver"
- patch -Np1 -i "${srcdir}/tools.patch"
-}
+#prepare() {
+# cd "$pkgname-$pkgver"
+# # patch if necessary
+#}
build() {
cd "$pkgname-$pkgver"
diff --git a/tools.patch b/tools.patch
deleted file mode 100644
index 9325010e00ac..000000000000
--- a/tools.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/tcl/tools.tcl 2012-11-22 22:34:00.000000000 +0100
-+++ b/tcl/tools.tcl 2018-08-03 12:41:39.614684540 +0200
-@@ -36,6 +36,7 @@
- return $h
- }
-
-+if {[llength [info commands lreverse]] == 0} {
- # return the same list in reverse order
- proc lreverse { list } {
-
-@@ -45,7 +46,9 @@
- }
- return $reverse
- }
-+}
-
-+if {[llength [info commands lmap]] == 0} {
- # aply command map on each element of list, returning the a new list
- proc lmap { list map } {
- set mapped {}
-@@ -54,6 +57,7 @@
- }
- return $mapped
- }
-+}
-
- # print line wrapped to specified width
- proc wrappedputs { line width } {