summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD33
2 files changed, 13 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07dcb406834e..3cf23ad94d3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = elvish
- pkgdesc = A friendly and expressive Unix shell.
+ pkgdesc = A friendly and expressive Unix shell
pkgver = 0.15.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/elves/elvish
install = elvish.install
arch = i686
arch = x86_64
- license = custom:2-clause BSD
+ license = BSD
makedepends = git
makedepends = go
- makedepends = pandoc
depends = glibc
provides = elvish
source = git+https://github.com/elves/elvish.git#tag=v0.15.0
diff --git a/PKGBUILD b/PKGBUILD
index 7bc094d92cf6..4c5edfff7b86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,40 @@
# Maintainer: Haochen Tong <i at hexchain dot org>
+# Maintainer: Qi Xiao <xiaqqaix at gmail dot com>
pkgname=elvish
pkgver=0.15.0
-pkgrel=1
-pkgdesc="A friendly and expressive Unix shell."
+pkgrel=2
+pkgdesc="A friendly and expressive Unix shell"
arch=('i686' 'x86_64')
url="https://github.com/elves/elvish"
-license=('custom:2-clause BSD')
+license=('BSD')
provides=('elvish')
-makedepends=('git' 'go' 'pandoc')
+makedepends=('git' 'go')
depends=('glibc')
source=("git+https://github.com/elves/elvish.git#tag=v$pkgver")
md5sums=('SKIP')
install=elvish.install
+
prepare() {
mkdir -p "$srcdir/build"
export GOPATH="$srcdir/build"
- export GOFLAGS="-buildmode=pie -trimpath -mod=vendor -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
cd "$srcdir/elvish"
go mod vendor
}
build() {
+ cd "$srcdir/elvish"
export GOPATH="$srcdir/build"
- export GOFLAGS="-buildmode=pie -trimpath -mod=vendor -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
export CGO_ENABLED=0
- cd "$srcdir/elvish"
go build -v -ldflags="-X github.com/elves/elvish/pkg/buildinfo.Version=$pkgver" .
-
- cd website
- mkdir -p "$srcdir/doc"
- go build -v ./cmd/elvdoc/
- for file in builtin edit epm language math platform readline-binding re store str unix; do
- ./elvdoc -filter < "ref/$file.md" | pandoc \
- -s -f gfm -t man -V section:7 \
- -V header:"Miscellaneous Information Manual" \
- -V footer:"Elvish $pkgver" -M date:"$(date -u --date=@${SOURCE_DATE_EPOCH} "+%b %d, %Y")" \
- -M title:"elvish-$file" \
- -o "$srcdir/doc/elvish-$file.7"
- done
}
check() {
export GOPATH="$srcdir/build"
- export GOFLAGS="-trimpath -mod=vendor -modcacherw"
+ export GOFLAGS="-trimpath -mod=readonly -modcacherw"
export CGO_ENABLED=1
cd "$srcdir/elvish"
make test
@@ -53,7 +43,4 @@ check() {
package() {
install -Dm755 "$srcdir/elvish/elvish" -t "$pkgdir/usr/bin/"
install -Dm644 "$srcdir/$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
-
- install -dm755 "$pkgdir/usr/share/man/man7"
- cp -rv --no-preserve=ownership "$srcdir/doc/"* "$pkgdir/usr/share/man/man7"
}