summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--Makefile13
-rw-r--r--PKGBUILD23
-rw-r--r--emacs.install36
4 files changed, 34 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cda9ff618bff..b2d32140939d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = emacs-24bit
pkgdesc = The extensible, customizable, self-documenting real-time display editor
- pkgver = 25.1
- pkgrel = 2
+ pkgver = 25.3
+ pkgrel = 4
url = http://www.gnu.org/software/emacs/emacs.html
- install = emacs.install
arch = i686
arch = x86_64
license = GPL3
@@ -16,21 +15,21 @@ pkgbase = emacs-24bit
depends = gtk3
depends = hicolor-icon-theme
depends = gconf
+ depends = desktop-file-utils
depends = alsa-lib
- depends = imagemagick
+ depends = libmagick6
depends = gnutls
- provides = emacs=25.1
+ provides = emacs=25.3
conflicts = emacs
conflicts = emacs-nox
- source = ftp://ftp.gnu.org/gnu/emacs/emacs-25.1.tar.xz
- source = ftp://ftp.gnu.org/gnu/emacs/emacs-25.1.tar.xz.sig
+ source = ftp://ftp.gnu.org/gnu/emacs/emacs-25.3.tar.xz
+ source = ftp://ftp.gnu.org/gnu/emacs/emacs-25.3.tar.xz.sig
source = https://gist.githubusercontent.com/choppsv1/3364fd6658ef498b5e06151217187017/raw/b9ba9e9000685abecf7ad954050b182eaef823e1/emacs-25.1-24bit.diff
- validpgpkeys = BE216115
validpgpkeys = B29426DEFB07724C3C35E5D36592E9A3A0B0F199
validpgpkeys = 28D3BED851FDF3AB57FEF93C233587A47C207910
- sha256sums = 19f2798ee3bc26c95dca3303e7ab141e7ad65d6ea2b6945eeba4dbea7df48f33
- sha256sums = SKIP
- sha256sums = e07dfcbe420c8fd08cc3286d6779fda6ca29ee14b05ed0c47ea1f417b90ea9b1
+ sha1sums = 1cb4f39e9c0a3305fd62f936c7c95ff8e2924323
+ sha1sums = SKIP
+ sha1sums = 3cdc4c178bf0f79042709ff32a472359d82b109e
pkgname = emacs-24bit
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..10020e9b9557
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+
+.PHONY: srcinfo
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+build: srcinfo
+ makepkg -cCsi
+
+release: srcinfo
+ git commit -a
+ git push
+
diff --git a/PKGBUILD b/PKGBUILD
index fbbec9554ac9..823b29b209b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,23 +8,20 @@
# Derived from standard emacs PKGBUILD
pkgname=emacs-24bit
-pkgver=25.1
-pkgrel=2
+pkgver=25.3
+pkgrel=4
pkgdesc="The extensible, customizable, self-documenting real-time display editor"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk3' 'hicolor-icon-theme' 'gconf' 'alsa-lib' 'imagemagick' 'gnutls')
-install=emacs.install
-validpgpkeys=('BE216115' 'B29426DEFB07724C3C35E5D36592E9A3A0B0F199' '28D3BED851FDF3AB57FEF93C233587A47C207910')
+depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk3' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib' 'libmagick6' 'gnutls')
+validpgpkeys=('B29426DEFB07724C3C35E5D36592E9A3A0B0F199' '28D3BED851FDF3AB57FEF93C233587A47C207910')
source=(ftp://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.xz{,.sig}
https://gist.githubusercontent.com/choppsv1/3364fd6658ef498b5e06151217187017/raw/b9ba9e9000685abecf7ad954050b182eaef823e1/emacs-25.1-24bit.diff)
-
-sha256sums=('19f2798ee3bc26c95dca3303e7ab141e7ad65d6ea2b6945eeba4dbea7df48f33'
- 'SKIP'
- 'e07dfcbe420c8fd08cc3286d6779fda6ca29ee14b05ed0c47ea1f417b90ea9b1')
-
-provides=('emacs=25.1')
+sha1sums=('1cb4f39e9c0a3305fd62f936c7c95ff8e2924323'
+ 'SKIP'
+ '3cdc4c178bf0f79042709ff32a472359d82b109e')
+provides=('emacs=25.3')
conflicts=(emacs emacs-nox)
prepare() {
@@ -34,8 +31,10 @@ prepare() {
build() {
cd "$srcdir"/emacs-$pkgver
+ PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig" \
ac_cv_lib_gif_EGifPutExtensionLast=yes ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --localstatedir=/var --with-x-toolkit=gtk3 --with-xft
+ --localstatedir=/var --with-x-toolkit=gtk3 --with-xft \
+ --with-modules
make
}
diff --git a/emacs.install b/emacs.install
deleted file mode 100644
index 64a719df5c81..000000000000
--- a/emacs.install
+++ /dev/null
@@ -1,36 +0,0 @@
-ICON_PATH=usr/share/icons/hicolor
-INFO_DIR=usr/share/info
-
-INFO_FILES=(ada-mode auth autotype bovine calc ccmode cl dbus dired-x ebrowse
-ede ediff edt efaq eieio eintr elisp emacs emacs-gnutls emacs-mime epa erc ert eshell eudc flymake
-forms gnus htmlfontify idlwave mairix-el message mh-e newsticker nxml-mode
-org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve smtpmail
-speedbar srecode tramp url vip viper widget wisent woman)
-
-post_install() {
- gtk-update-icon-cache -q -t -f ${ICON_PATH}
- if which update-desktop-database > /dev/null 2> /dev/null; then
- update-desktop-database -q
- fi
-
- [[ -x usr/bin/install-info ]] || return 0
- for f in ${INFO_FILES[@]}; do
- install-info ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- gtk-update-icon-cache -q -t -f ${ICON_PATH}
- if which update-desktop-database > /dev/null 2> /dev/null; then
- update-desktop-database -q
- fi
-
- [[ -x usr/bin/install-info ]] || return 0
- for f in ${INFO_FILES[@]}; do
- install-info --delete ${INFO_DIR}/$f.info.gz ${INFO_DIR}/dir 2> /dev/null
- done
-}