summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a870becd268e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = emacs-company-irony-c-headers-git
+ pkgdesc = Company-mode backend for C/C++ header files that works with irony-mode.
+ pkgver = 1.0.0.r2.g72c386a
+ pkgrel = 1
+ url = https://github.com/hotplx/company-irony-c-headers
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs-company-mode
+ depends = irony-mode
+ provides = emacs-company-irony-c-headers
+ source = git+https://github.com/hotplx/company-irony-c-headers.git
+ sha256sums = SKIP
+
+pkgname = emacs-company-irony-c-headers-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a945bc52bec6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Harms <thotro at lyse dot net>
+_gituser="hotpxl"
+_gitrepo="company-irony-c-headers"
+
+pkgname=emacs-company-irony-c-headers-git
+pkgver=1.0.0.r2.g72c386a
+pkgrel=1
+pkgdesc="Company-mode backend for C/C++ header files that works with irony-mode."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+provides=('emacs-company-irony-c-headers')
+depends=('emacs-company-mode' 'irony-mode')
+makedepends=('git')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver()
+{
+ cd "${_gitrepo}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build()
+{
+ cd "${_gitrepo}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package()
+{
+ cd "${_gitrepo}"
+ install -d "${pkgdir}"/usr/share/emacs/site-lisp/"${_gitrepo}"/
+ install -m644 *.el{c,} "${pkgdir}"/usr/share/emacs/site-lisp/${_gitrepo}/
+}