summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0949b9ddc3bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = emacs-dbus-introspection
+ pkgdesc = A framework that makes accessing remote D-Bus objects from Emacs Lisp easier
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://bazaar.launchpad.net/~scymtym/+junk/dbus-proxy/
+ arch = any
+ license = GPL
+ depends = emacs
+ source = http://bazaar.launchpad.net/~scymtym/+junk/dbus-proxy/download/scymtym%40gmx.net-20100824014654-ifbwtut1heda3tu7/dbusintrospection.el-20090825015526-rsd6s9n5ebqeuqwm-1/dbus-introspection.el
+ md5sums = cac49e72688a9780efdba750b6dd2122
+
+pkgname = emacs-dbus-introspection
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0275bf12349a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=emacs-dbus-introspection
+pkgver=0.1
+pkgrel=1
+pkgdesc="A framework that makes accessing remote D-Bus objects from Emacs Lisp easier"
+arch=('any')
+url="http://bazaar.launchpad.net/~scymtym/+junk/dbus-proxy/"
+license=('GPL')
+depends=('emacs')
+source=('http://bazaar.launchpad.net/~scymtym/+junk/dbus-proxy/download/scymtym%40gmx.net-20100824014654-ifbwtut1heda3tu7/dbusintrospection.el-20090825015526-rsd6s9n5ebqeuqwm-1/dbus-introspection.el')
+md5sums=('cac49e72688a9780efdba750b6dd2122')
+
+build() {
+ cd "$srcdir/$_bzrmod"
+ emacs -batch -q -f batch-byte-compile dbus-introspection.el
+}
+
+package() {
+ cd "$srcdir/$_bzrmod"
+ install -Dm644 dbus-introspection.el \
+ $pkgdir/usr/share/emacs/site-lisp/dbus-introspection.el
+ install -Dm644 dbus-introspection.elc \
+ $pkgdir/usr/share/emacs/site-lisp/dbus-introspection.elc
+}