summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--emacs-evil.install13
3 files changed, 7 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 932d07d4b906..7176966f5125 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = emacs-evil-git
pkgdesc = The extensible vi layer for Emacs.
- pkgver = 1.2.14.r3.g297b8f3
+ pkgver = 1.14.0.r94.gee6f4bd
pkgrel = 1
url = https://github.com/emacs-evil/evil
- install = emacs-evil.install
arch = any
license = GPL3
- makedepends = git
+ makedepends = python-sphinx
depends = emacs
depends = emacs-undo-tree
provides = emacs-evil
@@ -15,4 +14,3 @@ pkgbase = emacs-evil-git
sha256sums = SKIP
pkgname = emacs-evil-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2a1598f0243f..3ce288d5d9bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
-# Maintainer: LinRs <LinRs AT users.noreply.github.com>
+# Maintainer: hamki <hamki.do2000@gmail.com>
+# Contributor: LinRs <LinRs AT users.noreply.github.com>
# Contributor: sballert <sballert@posteo.de>
_gituser="emacs-evil"
_gitrepo="evil"
pkgname=emacs-evil-git
-pkgver=1.2.14.r3.g297b8f3
+pkgver=1.14.0.r94.gee6f4bd
pkgrel=1
pkgdesc="The extensible vi layer for Emacs."
url="https://github.com/${_gituser}/${_gitrepo}"
arch=('any')
license=('GPL3')
depends=('emacs' 'emacs-undo-tree')
-makedepends=('git')
+makedepends=('python-sphinx')
provides=('emacs-evil')
conflicts=('emacs-evil')
source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
-install="${_gituser}.install"
sha256sums=('SKIP')
pkgver() {
@@ -37,7 +37,7 @@ package() {
cd "${srcdir}/${_gitrepo}"
install -d "${pkgdir}/usr/share/emacs/site-lisp/${_gitrepo}"
install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_gitrepo}/"
- cd "${srcdir}/${_gitrepo}/doc"
+ cd "${srcdir}/${_gitrepo}/doc/build/texinfo"
install -d "${pkgdir}/usr/share/info"
install -m644 ${_gitrepo}.info "${pkgdir}/usr/share/info/"
}
diff --git a/emacs-evil.install b/emacs-evil.install
deleted file mode 100644
index 7b659fd32b50..000000000000
--- a/emacs-evil.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
-cat << EOF
-
->>> (add-to-list 'load-path "~/.emacs.d/evil")
->>> (require 'evil)
->>> (evil-mode 1)
-
-EOF
-}
-
-post_upgrade() {
- post_install
-} \ No newline at end of file