summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7728b765167..027e5a7aa0d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = emacs-markup-faces
- pkgdesc = As font-lock-faces, but tailored for markup languages instead programming languages
+ pkgdesc = Like font-lock-faces, but tailored for markup languages instead programming languages
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/sensorflo/markup-faces
arch = any
- license = GPL
+ license = GPL3
depends = emacs
- source = git+http://github.com/sensorflo/markup-faces#commit=c43612633c6c161857a3bab5752ae192bb03f5f3
- md5sums = SKIP
+ source = emacs-markup-faces-1.0.0.tar.gz::http://github.com/sensorflo/markup-faces/archive/V1.0.0.tar.gz
+ sha256sums = 39373f227eaf4ad72be4438ba36bbb2d581672c609f30d81b3a32fce46eb3f41
pkgname = emacs-markup-faces
diff --git a/PKGBUILD b/PKGBUILD
index 5a8ca9e1cd14..063f9db20e80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
-# Maintainer: Oliver Mangold
+# Contributor: Oliver Mangold
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-markup-faces
pkgver=1.0.0
-pkgrel=1
-pkgdesc="As font-lock-faces, but tailored for markup languages instead programming languages"
+pkgrel=2
+pkgdesc="Like font-lock-faces, but tailored for markup languages instead programming languages"
arch=('any')
url="http://github.com/sensorflo/markup-faces"
-license=('GPL')
+license=('GPL3')
depends=('emacs')
-source=(git+http://github.com/sensorflo/markup-faces#commit=c43612633c6c161857a3bab5752ae192bb03f5f3)
-md5sums=(SKIP)
+source=("$pkgname-$pkgver.tar.gz::http://github.com/sensorflo/${pkgname#emacs-}/archive/V$pkgver.tar.gz")
+sha256sums=('39373f227eaf4ad72be4438ba36bbb2d581672c609f30d81b3a32fce46eb3f41')
+
+build() {
+ emacs -batch -q -f batch-byte-compile ${pkgname#emacs-}-$pkgver/${pkgname#emacs-}.el
+}
package() {
# Install the mode for Emacs
- install -D -m644 "$srcdir/markup-faces/markup-faces.el" "$pkgdir/usr/share/emacs/site-lisp/markup-faces.el"
+ install -D -m644 "$srcdir"/${pkgname#emacs-}-$pkgver/${pkgname#emacs-}.el \
+ "$pkgdir"/usr/share/emacs/site-lisp/${pkgname#emacs-}.el
+ install -D -m644 "$srcdir"/${pkgname#emacs-}-$pkgver/${pkgname#emacs-}.elc \
+ "$pkgdir"/usr/share/emacs/site-lisp/${pkgname#emacs-}.elc
}