summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73f2ff984c0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-smartparens-git
+ pkgdesc = Minor mode for Emacs that deals with parens pairs and tries to be smart about
+ pkgver = r1417.14a4d62
+ pkgrel = 1
+ url = https://github.com/Fuco1/smartparens
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-dash
+ provides = emacs-smartparens
+ conflicts = emacs-smartparens
+ source = git+https://github.com/Fuco1/smartparens.git
+ sha256sums = SKIP
+
+pkgname = emacs-smartparens-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7284b65bd60a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="Fuco1"
+_gitrepo="smartparens"
+
+pkgname=emacs-smartparens-git
+pkgver=r1417.14a4d62
+pkgrel=1
+pkgdesc="Minor mode for Emacs that deals with parens pairs and tries to be smart about"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-dash')
+makedepends=('git')
+provides=('emacs-smartparens')
+conflicts=('emacs-smartparens')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}