summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD49
-rw-r--r--emacspeak-git.install13
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bbbf532221a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = emacspeak-git
+ pkgdesc = Emacs extension that provides spoken output
+ pkgver = r10930.29aded1
+ pkgrel = 1
+ url = http://emacspeak.sourceforge.net/
+ install = emacspeak-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = git
+ depends = emacs
+ depends = tcl>=8.6
+ depends = tcl<8.7
+ depends = tclx
+ depends = espeak
+ optdepends = eflite: software speech via the FLite TTS engine
+ provides = emacspeak
+ conflicts = emacspeak
+ source = emacspeak-git::git://github.com/tvraman/emacspeak.git
+ md5sums = SKIP
+
+pkgname = emacspeak-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d73b884f930
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Steve Holmes <steve.holmes88@gmail.com>
+# Contributors: Chris Brannon <cmbrannon79@gmail.com>
+pkgname=emacspeak-git
+pkgver=r10930.29aded1
+pkgrel=1
+pkgdesc="Emacs extension that provides spoken output"
+arch=(i686 x86_64)
+url="http://emacspeak.sourceforge.net/"
+license=('GPL' 'custom')
+depends=('emacs' 'tcl>=8.6' 'tcl<8.7' 'tclx' 'espeak')
+optdepends=( 'eflite: software speech via the FLite TTS engine')
+makedepends=('git')
+provides=(emacspeak)
+conflicts=(emacspeak)
+install='emacspeak-git.install'
+source=(${pkgname}::'git://github.com/tvraman/emacspeak.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${srcdir}/${pkgname}
+ sed -i -e 's, /etc/info-dir, $(DESTDIR)$(infodir)/dir,g;s, $(infodir)/, $(DESTDIR)$(infodir)/,' info/Makefile
+}
+
+build() {
+ cd ${srcdir}/${pkgname}
+ make config
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ make prefix="${pkgdir}/usr" install
+ # Espeak isn't compiled by default, but lots of folks use it.
+ cd "$pkgdir/usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak"
+ make TCL_VERSION=8.6
+ rm -f tclespeak.cpp Makefile
+ # A handful of files have permissions of 750 and 640; fix.
+ #cd ${pkgdir}
+ #find . -perm 640 -print0
+ #find . -perm 750 -print0
+ gzip -9nf ${pkgdir}/usr/share/info/*
+ rm -f "$pkgdir/usr/share/info/dir"
+}
+
diff --git a/emacspeak-git.install b/emacspeak-git.install
new file mode 100644
index 000000000000..399c46a93a32
--- /dev/null
+++ b/emacspeak-git.install
@@ -0,0 +1,13 @@
+INFO_DIR=/usr/share/info
+
+post_install() {
+ install-info ${INFO_DIR}/emacspeak*.info.gz ${INFO_DIR}/dir 2> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ install-info --delete ${INFO_DIR}/emacspeak*.info.gz ${INFO_DIR}/dir 2> /dev/null
+}