summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE41
-rw-r--r--PKGBUILD40
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75f9e35938f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = embeetle-ide
+ pkgdesc = A new IDE for microcontrollers, built from scratch
+ pkgver = 0.2.6
+ pkgrel = 1
+ url = https://embeetle.com
+ arch = x86_64
+ license = custom
+ depends = gtk3
+ depends = qt5-svg
+ depends = qt5-tools
+ depends = qt5-sensors
+ depends = qt5-location
+ depends = qt5-x11extras
+ depends = qt5-multimedia
+ depends = qt5-webchannel
+ source = embeetle-ide-0.2.6::https://embeetle.com/downloads/linux/embeetle.tar.gz
+ source = LICENSE
+ sha256sums = 8a42d1429eae8500348ea79251b6da925a318081ed5f2360dd42fe28cd42eae6
+ sha256sums = d5353ae25be837afd2dbd385a5bc6dc580e007c786798795d045b4d799bebcf1
+
+pkgname = embeetle-ide
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..399d8bba9543
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,41 @@
+Embeetle license
+================
+Copyright (c) 2020, Matic Kukovec, Kristof Mulier and Johan Cockx.
+
+This license applies to the Embeetle software developed by the above copyright
+holders. It does not apply to third party software that is distributed with
+Embeetle. Such software generally has its own license.
+
+By downloading, using and/or distributing the Embeetle software, you agree to
+be bound by the terms of this license.
+
+Permission is hereby granted to use this software without modification.
+
+Permission is hereby granted to distribute this software without modification
+and without a fee.
+
+THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHORS AND COPYRIGHT HOLDERS DISCLAIM
+ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY
+DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+
+Alternative licenses
+====================
+
+Under the above license:
+
+- No permission is granted to modify the Embeetle software in any way.
+
+- No permission is granted to use, copy or distribute a modified version of the
+ Embeetle software.
+
+- No permission is granted to distribute Embeetle for a fee.
+
+We are interested in distributing Embeetle under other licenses as well. If you
+wish to use or distribute a modified version of this software, or if you wish to
+use this software under a different license, please contact us at
+info@embeetle.com. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1fd11777d50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=embeetle-ide
+pkgver=0.2.6
+pkgrel=1
+pkgdesc="A new IDE for microcontrollers, built from scratch"
+arch=('x86_64')
+url='https://embeetle.com'
+license=('custom')
+depends=('gtk3'
+ 'qt5-svg'
+ 'qt5-tools'
+ 'qt5-sensors'
+ 'qt5-location'
+ 'qt5-x11extras'
+ 'qt5-multimedia'
+ 'qt5-webchannel')
+source=("${pkgname}-${pkgver}::https://embeetle.com/downloads/linux/embeetle.tar.gz"
+ "LICENSE")
+sha256sums=('8a42d1429eae8500348ea79251b6da925a318081ed5f2360dd42fe28cd42eae6'
+ 'd5353ae25be837afd2dbd385a5bc6dc580e007c786798795d045b4d799bebcf1')
+
+package() {
+ install -d "${pkgdir}/opt/" "${pkgdir}/usr/share/pixmaps"
+ cp -avR "${srcdir}/embeetle" "${pkgdir}/opt/"
+ echo "#!/bin/env bash
+ cd /opt/embeetle/beetle_core/
+ ./embeetle" > embeetle-ide.sh
+ install -Dm755 embeetle-ide.sh "${pkgdir}/usr/bin/embeetle-ide"
+ gendesk -f -n --pkgname "${pkgname}" \
+ --pkgdesc "${pkgdesc}" \
+ --name "Embeetle IDE" \
+ --comment "${pkgdesc}" \
+ --exec "${pkgname}" \
+ --categories 'Utility;Development;IDE;'
+ install -Dm644 embeetle-ide.desktop -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/embeetle/beetle_core/resources/icons/square_logo.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}