summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE.md21
-rw-r--r--PKGBUILD31
3 files changed, 21 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7653ff7f6fc5..457dc7272be3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = emulsion-bin
pkgdesc = A fast and minimalistic image viewer (binary release)
- pkgver = 9.0
- pkgrel = 2
- url = https://arturkovacs.github.io/emulsion-website
+ pkgver = 10.4
+ pkgrel = 1
+ url = https://github.com/ArturKovacs/emulsion
arch = x86_64
license = MIT
- makedepends = dpkg
- depends = gcc-libs
- optdepends = hicolor-icon-theme
+ depends = hicolor-icon-theme
+ depends = libavif
provides = emulsion
conflicts = emulsion
- options = !emptydirs
- source = emulsion-9.0.deb::https://github.com/arturkovacs/emulsion/releases/download/v9.0/Emulsion-Linux.deb-v9.0.deb
- sha256sums = f66ab3b655af4da6e4c3fb60540c241cc9e7055ab70a0638aedd8af484d90427
+ source = https://github.com/ArturKovacs/emulsion/releases/download/v10.4/Emulsion-Linux.deb-v10.4.deb
+ sha256sums = 823fde86860ded2335c59114fc377fc02d14738ba5c1040cce54c501f5516a3f
pkgname = emulsion-bin
-
diff --git a/LICENSE.md b/LICENSE.md
deleted file mode 100644
index 74e2787c5da8..000000000000
--- a/LICENSE.md
+++ /dev/null
@@ -1,21 +0,0 @@
-# The MIT License
-
-Copyright © 2020 Hoàng Văn Khải
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 4beecb179a66..7e6efb13380d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+# Contributor: Luis Martinez <luis dot martinez at tuta dot io>
# Contributor: Szymon Scholz <first name last name [at] gmail [dot] com>
pkgname=emulsion-bin
-_name="${pkgname%-bin}"
-pkgver=9.0
-pkgrel=2
+pkgver=10.4
+pkgrel=1
pkgdesc="A fast and minimalistic image viewer (binary release)"
+url="https://github.com/ArturKovacs/emulsion"
arch=('x86_64')
-url="https://arturkovacs.github.io/emulsion-website"
license=('MIT')
-depends=('gcc-libs')
-makedepends=('dpkg')
-optdepends=('hicolor-icon-theme')
-provides=("$_name")
-conflicts=("$_name")
-options=(!emptydirs)
-source=("$_name-$pkgver.deb::https://github.com/arturkovacs/emulsion/releases/download/v$pkgver/Emulsion-Linux.deb-v$pkgver.deb")
-sha256sums=('f66ab3b655af4da6e4c3fb60540c241cc9e7055ab70a0638aedd8af484d90427')
+depends=('hicolor-icon-theme' 'libavif')
+provides=("emulsion")
+conflicts=("emulsion")
+source=("$url/releases/download/v$pkgver/Emulsion-Linux.deb-v$pkgver.deb")
+sha256sums=('823fde86860ded2335c59114fc377fc02d14738ba5c1040cce54c501f5516a3f')
package() {
- dpkg-deb --extract "$_name-$pkgver.deb" "$pkgdir/"
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- mv "$pkgdir/usr/lib/$_name/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/"
- chown -R root:root "$pkgdir/"
+ tar -C "$pkgdir" -xf data.tar.gz
+ install -Dm644 "$pkgdir/usr/lib/emulsion/LICENSE.txt" -t "$pkgdir/usr/share/licenses/emulsion"
+# Fix error
+ ln -s /usr/lib/libdav1d.so "$pkgdir/usr/lib/libdav1d.so.6"
}