summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8d97b920f6e..57c6b40476f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = envoy-git
pkgdesc = A ssh-agent/gpg-agent keychain and process monitor
- pkgver = 12
+ pkgver = 14.35.g50c069f
pkgrel = 1
url = http://github.com/vodik/envoy
arch = i686
arch = x86_64
- license = GPL
+ license = GPL-3.0-only
makedepends = git
makedepends = ragel
depends = openssh
@@ -13,8 +13,7 @@ pkgbase = envoy-git
optdepends = gnupg: gpg-agent support
provides = envoy
conflicts = envoy
- source = git+git://github.com/vodik/envoy.git
+ source = git+https://github.com/vodik/envoy.git
sha1sums = SKIP
pkgname = envoy-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 13024f24f55a..e598220dc419 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Simon Gomizelj <simongmzlj@gmail.com>
+# Contributor: Simon Gomizelj <simongmzlj@gmail.com>
pkgname=envoy-git
-pkgver=12
-pkgver() {
- cd "envoy"
- git describe | sed 's/^v//;s/-/./g'
-}
+pkgver=14.35.g50c069f
pkgrel=1
pkgdesc="A ssh-agent/gpg-agent keychain and process monitor"
-
arch=('i686' 'x86_64')
url="http://github.com/vodik/envoy"
-license=('GPL')
+license=('GPL-3.0-only')
depends=('openssh' 'systemd')
optdepends=('gnupg: gpg-agent support')
makedepends=('git' 'ragel')
conflicts=('envoy')
provides=('envoy')
-source=('git+git://github.com/vodik/envoy.git')
+source=('git+https://github.com/vodik/envoy.git')
sha1sums=('SKIP')
+pkgver() {
+ cd "envoy"
+ git describe | sed 's/^v//;s/-/./g'
+}
+
build() {
make -C "envoy"
}