summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5409d0ece4a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = erlang-sdl
+ pkgdesc = SDL and OpenGL bindings for Erlang
+ pkgver = 1.3.1
+ pkgrel = 4
+ url = https://github.com/dgud/esdl/
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = mesa-libgl
+ makedepends = rebar
+ depends = erlang
+ depends = glu
+ depends = libgl
+ depends = sdl
+ source = esdl::git+https://github.com/dgud/esdl/#commit=dbd8ce9228aa
+ md5sums = SKIP
+
+pkgname = erlang-sdl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a98be764dbb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer:
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: kappa <kappacurve@gmail.com>
+
+pkgname=erlang-sdl
+pkgver=1.3.1
+pkgrel=4
+arch=('x86_64')
+pkgdesc='SDL and OpenGL bindings for Erlang'
+url='https://github.com/dgud/esdl/'
+license=(custom)
+depends=(erlang glu libgl sdl)
+makedepends=(git mesa-libgl rebar)
+#tag=esdl-1.3.1 fails
+source=("esdl::git+$url#commit=dbd8ce9228aa")
+md5sums=('SKIP')
+
+prepare() {
+ find esdl -type f -exec chmod 644 {} \;
+}
+
+build() {
+ cd esdl
+ CFLAGS="$CFLAGS -Wno-deprecated-declarations" rebar compile
+}
+
+package() {
+ cd esdl
+ install -d "$pkgdir/usr/lib/erlang/lib/esdl-$pkgver"
+ cp -ruv c_src doc ebin include priv src \
+ "$pkgdir/usr/lib/erlang/lib/esdl-$pkgver/"
+ install -Dm644 license.terms "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}