summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
-rw-r--r--esound.service8
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db2141bf0ab3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = esound
+ pkgdesc = Enlightened Sound Daemon
+ pkgver = 0.2.41
+ pkgrel = 4
+ url = http://www.tux.org/~ricdude/EsounD.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = audiofile
+ provides = esd=0.2.41
+ conflicts = esd
+ options = !libtool
+ backup = etc/esd.conf
+ source = http://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-0.2.41.tar.bz2
+ source = esound.service
+ md5sums = 8d9aad3d94d15e0d59ba9dc0ea990c6c
+ md5sums = c3f08e2930bcc9dd0fa4142b98413832
+
+pkgname = esound
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..025d056e9a15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer : SpepS <dreamspepser at yahoo dot it>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=esound
+pkgver=0.2.41
+pkgrel=4
+pkgdesc="Enlightened Sound Daemon"
+arch=('i686' 'x86_64')
+url="http://www.tux.org/~ricdude/EsounD.html"
+license=('LGPL')
+depends=('audiofile')
+provides=("esd=$pkgver")
+conflicts=('esd')
+backup=('etc/esd.conf')
+options=('!libtool')
+source=("http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+ esound.service)
+md5sums=('8d9aad3d94d15e0d59ba9dc0ea990c6c'
+ 'c3f08e2930bcc9dd0fa4142b98413832')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # alsa drain fix
+ sed -i 's/drain/drop/' audio_alsa09.c
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --with-audiofile \
+ --without-libwrap \
+ --enable-alsa \
+ --disable-artstest
+ make CFLAGS="$CFLAGS -lm"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+
+ # daemon
+ install -Dm644 ../esound.service "$pkgdir/usr/lib/systemd/system/esound.service"
+}
diff --git a/esound.service b/esound.service
new file mode 100644
index 000000000000..3bd1a2b0d2fd
--- /dev/null
+++ b/esound.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Enlightened Sound Daemon
+
+[Service]
+ExecStart=/usr/bin/esd -nobeeps
+
+[Install]
+WantedBy=multi-user.target