summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0009fcef2fb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = estilo-git
+ pkgdesc = Create and maintain colorschemes for vim, airline, and lightline
+ pkgver = r253.3e86a39
+ pkgrel = 1
+ url = https://github.com/jacoborus/estilo
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ depends = bash
+ depends = gnuplot
+ depends = nodejs
+ depends = perl
+ provides = estilo
+ conflicts = estilo
+ source = estilo-git::git+https://github.com/jacoborus/estilo
+ md5sums = SKIP
+
+pkgname = estilo-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73de0d900192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a56e5fdf9b99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+pkgname=estilo-git
+pkgver=r253.3e86a39
+pkgrel=1
+pkgdesc="Create and maintain colorschemes for vim, airline, and lightline"
+arch=('any')
+url="https://github.com/jacoborus/estilo"
+license=('MIT')
+depends=('bash' 'gnuplot' 'nodejs' 'perl')
+makedepends=('git' 'npm')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ tar czf "$pkgname-$pkgver.tar.gz" "$pkgname"
+}
+
+package() {
+ npm install --cache "$srcdir/npm-cache" -g --prefix "$pkgdir/usr" "$pkgname-$pkgver.tar.gz"
+ find "$pkgdir/usr" -type d -name '.git' -exec rm -rf '{}' +
+ chown -R root:root "$pkgdir/"
+}