summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD10
-rw-r--r--etqw.install2
4 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c28ccd04e6a..abff24084b76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
pkgbase = etqw
pkgdesc = Enemy Territory: Quake Wars is a commercial team and class-based multiplayer game. You need the retail DVD to play.
pkgver = 1.5
- pkgrel = 4
- url = http://zerowing.idsoftware.com/linux/etqw/ETQWFrontPage/
+ pkgrel = 5
+ url = https://zerowing.idsoftware.com/linux/etqw/ETQWFrontPage/index.html
install = etqw.install
arch = i686
arch = x86_64
license = custom
makedepends = unzip
- depends = libgl
- depends = sdl
- depends = gcc-libs
- depends = zlib
- depends = libjpeg
+ depends = lib32-alsa-lib
+ depends = lib32-libgl
+ depends = lib32-sdl
+ depends = lib32-gcc-libs
+ depends = lib32-zlib
+ depends = lib32-libjpeg
conflicts = bin32-etqw
source = etqw.launcher
source = etqw-rthread.launcher
source = etqwded.launcher
source = etqw.desktop
- source = ftp://ftp.uwsg.indiana.edu/linux/gentoo/distfiles/ETQW-client-1.5-full.x86.run
+ source = https://slashbunny.com/aur/etqw/ETQW-client-1.5-full.x86.run
sha256sums = 79393825ab93bb9cecee69ad6ddafdaef3526bf9f757023325bfffc228ad920c
sha256sums = 38140d4465f7e337e4e079150576abaed9ed8cd51b4092b434a7d6ae619998b4
sha256sums = 74887f52f0a82fe241bd5a99a1287c26c3c52ef4314cf6720cf3f59c9ad3a62e
@@ -26,4 +27,3 @@ pkgbase = etqw
sha256sums = 827395c5ad7bff36a8456f7f210ab43b8cc2b0d18e9f366d15ff4f11eacfc4c5
pkgname = etqw
-
diff --git a/.gitignore b/.gitignore
index e4f398dc5b3a..922c36ca14b9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
src/
pkg/
-*.pkg.tar.xz
*.pkg.tar
-*.src.tar.gz
+ETQW-client-1.5-full.x86.run
diff --git a/PKGBUILD b/PKGBUILD
index 6fbf94c41350..6eb81be81cae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=etqw
pkgver=1.5
-pkgrel=4
+pkgrel=5
pkgdesc="Enemy Territory: Quake Wars is a commercial team and class-based multiplayer game. You need the retail DVD to play."
arch=('i686' 'x86_64')
-url="http://zerowing.idsoftware.com/linux/etqw/ETQWFrontPage/"
+url="https://zerowing.idsoftware.com/linux/etqw/ETQWFrontPage/index.html"
license=('custom')
if [ "$CARCH" = "x86_64" ]; then
depends=('lib32-alsa-lib' 'lib32-libgl' 'lib32-sdl' 'lib32-gcc-libs' 'lib32-zlib' 'lib32-libjpeg')
@@ -16,13 +16,12 @@ makedepends=('unzip')
conflicts=('bin32-etqw')
install='etqw.install'
source=('etqw.launcher' 'etqw-rthread.launcher' 'etqwded.launcher' 'etqw.desktop' \
-"ftp://ftp.uwsg.indiana.edu/linux/gentoo/distfiles/ETQW-client-${pkgver}-full.x86.run")
+"https://slashbunny.com/aur/etqw/ETQW-client-${pkgver}-full.x86.run")
sha256sums=('79393825ab93bb9cecee69ad6ddafdaef3526bf9f757023325bfffc228ad920c'
'38140d4465f7e337e4e079150576abaed9ed8cd51b4092b434a7d6ae619998b4'
'74887f52f0a82fe241bd5a99a1287c26c3c52ef4314cf6720cf3f59c9ad3a62e'
'ed85a82636aed87c54268d84f0f7e09a0a7a37b0def9415fd8791684c5e90288'
'827395c5ad7bff36a8456f7f210ab43b8cc2b0d18e9f366d15ff4f11eacfc4c5')
-PKGEXT='.pkg.tar'
package() {
# Create Destination Directories
@@ -70,5 +69,8 @@ package() {
# Create Directories for Retail Files
install -d ${pkgdir}/opt/etqw/base/{megatextures,video}
+
+ # Remove breaking local libraries
+ rm ${pkgdir}/opt/etqw/{libgcc_s.so.1,libstdc++.so.6}
}
diff --git a/etqw.install b/etqw.install
index 2a44d91ba562..120c3e6891bb 100644
--- a/etqw.install
+++ b/etqw.install
@@ -10,6 +10,8 @@ post_install() {
echo ">>> Setup/Data/base/megatextures/* to /opt/etqw/base/megatextures"
echo ">>> Setup/Data/base/video/* to /opt/etqw/base/video"
echo ">>>"
+ echo ">>> Alternatively, you may use the etqw-data PKGBUILD on the AUR"
+ echo ">>>"
echo ">>> When you have the data files installed, start the game:"
echo ">>> Client: etqw"
echo ">>> Server: etqw-dedicated"