summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ad359d15b6e..a57d1eebc50e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,4 @@
- # This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# Maintainer: Your Name <youremail@domain.com
+# Maintainer: utsi <youremail@domain.com
_pkgname=evdevhook
pkgname=${_pkgname}-git
pkgdesc="DSU server for motion from evdev compatible joysticks"
@@ -19,9 +14,9 @@ source=("${_pkgname}::git+${url}")
md5sums=('SKIP')
build() {
- cmake -B build -S "${pkgver}" \
+ cmake -B build -S "${_pkgname}" \
-DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' ${_pkgname}
+ -DCMAKE_INSTALL_PREFIX='/usr'
make -j -C build
}
@@ -29,8 +24,6 @@ package() {
cd build
make DESTDIR="$pkgdir/" install
cd "$srcdir/$_pkgname"
- pwd
- ls
install -Dm644 "config_templates"/* -t "${pkgdir}/usr/share/doc/${_pkgname}"
}