summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD54
2 files changed, 59 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8162b6b7c563..9b0e562d2071 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,41 @@
pkgbase = exaile
pkgdesc = A full-featured Amarok-style media player for GTK+
- pkgver = 4.0.2
+ pkgver = 4.1.3
pkgrel = 1
url = https://www.exaile.org/
arch = any
license = GPL2
- checkdepends = python2-mox3
- checkdepends = python2-pytest
+ checkdepends = python-pytest
+ makedepends = pygobject-devel>=3.24.0
makedepends = help2man
- depends = python2>=2.7
- depends = gtk3>=3.10.0
- depends = gst-python2>=1.4.0
- depends = gst-plugins-base>=1.6.0
- depends = gst-plugins-good>=1.4.0
- depends = python2-mutagen>=1.10.0
- depends = python2-dbus
- depends = pygobject-devel>=3.13.2
- depends = python2-cairo
+ depends = python>=3.8
+ depends = python-bsddb
+ depends = gtk3>=3.24.0
+ depends = gst-python>=1.16.0
+ depends = gst-plugins-base>=1.16.0
+ depends = gst-plugins-good>=1.16.0
+ depends = python-mutagen>=1.44.0
+ depends = python-dbus
+ depends = python-cairo
+ depends = python-gobject>=3.24.0
optdepends = udisks2: device detection
- optdepends = cddb-py: CD info
- optdepends = spydaap: DAAP plugins (daapserver and daapclient)
- optdepends = python2-pylast: Last.FM integration
- optdepends = python2-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)
- optdepends = python2-musicbrainzngs: Musicbrainz covers
- optdepends = python2-feedparser: podcast plugin
+ optdepends = python-discid: CD info
+ optdepends = python-musicbrainzngs: CD info / Musicbrainz covers
+ optdepends = spydaap: DAAP server
+ optdepends = python-zeroconf: DAAP plugins (daapserver and daapclient)
+ optdepends = python-pylast: Last.FM integration
+ optdepends = python-lxml: lyrics from lyricsmania.com (lyricsmania)
+ optdepends = python-feedparser: podcast plugin
optdepends = webkit2gtk: Wikipedia info
optdepends = libkeybinder3: Xlib-based hotkeys
optdepends = librsvg: scalable icons
- source = https://github.com/exaile/exaile/releases/download/4.0.2/exaile-4.0.2.tar.gz
- sha512sums = 4b0629d68d426493b8ba9295c755919c9d9919ee916952339b06206b8e1eb86145e5c5975cc21ecd8b9ab6b266eaaff0855e9a5154beb951033564a6dcf0ca37
+ optdepends = libnotify: native notifications
+ optdepends = streamripper: recording streams
+ optdepends = moodbar: moodbar plugin
+ optdepends = gst-plugins-bad: BPM Counter plugin
+ optdepends = python-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)
+ optdepends = ipython: ipconsole plugin
+ source = exaile-4.1.3.tar.gz::https://github.com/exaile/exaile/archive/4.1.3.tar.gz
+ sha512sums = 16b31331a31f0a2e088f177c8a01ef47603b07fe94cbb19869a4caeaec2da03cacaa07d5b0eb50052645449e07620e2c58f202007108af73e20cf744d70bb556
pkgname = exaile
-
diff --git a/PKGBUILD b/PKGBUILD
index 43b0efd90239..89a96a85c20b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: X0rg
+# Maintainer: UnicornDarkness
# Contributor: Tom Kwok <contact@tomkwok.com>
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
@@ -7,35 +7,43 @@
# Contributor: Joshua Stiefer <facedelajunk@gmail.com>
pkgname=exaile
-pkgver=4.0.2
+pkgver=4.1.3
pkgrel=1
pkgdesc="A full-featured Amarok-style media player for GTK+"
arch=('any')
url="https://www.exaile.org/"
license=('GPL2')
-depends=('python2>=2.7'
- 'gtk3>=3.10.0'
- 'gst-python2>=1.4.0'
- 'gst-plugins-base>=1.6.0'
- 'gst-plugins-good>=1.4.0'
- 'python2-mutagen>=1.10.0'
- 'python2-dbus'
- 'pygobject-devel>=3.13.2'
- 'python2-cairo')
-makedepends=('help2man')
-checkdepends=('python2-mox3' 'python2-pytest')
+depends=('python>=3.8'
+ 'python-bsddb'
+ 'gtk3>=3.24.0'
+ 'gst-python>=1.16.0'
+ 'gst-plugins-base>=1.16.0'
+ 'gst-plugins-good>=1.16.0'
+ 'python-mutagen>=1.44.0'
+ 'python-dbus'
+ 'python-cairo'
+ 'python-gobject>=3.24.0')
+makedepends=('pygobject-devel>=3.24.0' 'help2man')
+checkdepends=('python-pytest')
optdepends=('udisks2: device detection'
- 'cddb-py: CD info'
- 'spydaap: DAAP plugins (daapserver and daapclient)'
- 'python2-pylast: Last.FM integration'
- 'python2-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)'
- 'python2-musicbrainzngs: Musicbrainz covers'
- 'python2-feedparser: podcast plugin'
+ 'python-discid: CD info'
+ 'python-musicbrainzngs: CD info / Musicbrainz covers'
+ 'spydaap: DAAP server'
+ 'python-zeroconf: DAAP plugins (daapserver and daapclient)'
+ 'python-pylast: Last.FM integration'
+ 'python-lxml: lyrics from lyricsmania.com (lyricsmania)'
+ 'python-feedparser: podcast plugin'
'webkit2gtk: Wikipedia info'
'libkeybinder3: Xlib-based hotkeys'
- 'librsvg: scalable icons')
-source=("https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
-sha512sums=('4b0629d68d426493b8ba9295c755919c9d9919ee916952339b06206b8e1eb86145e5c5975cc21ecd8b9ab6b266eaaff0855e9a5154beb951033564a6dcf0ca37')
+ 'librsvg: scalable icons'
+ 'libnotify: native notifications'
+ 'streamripper: recording streams'
+ 'moodbar: moodbar plugin'
+ 'gst-plugins-bad: BPM Counter plugin'
+ 'python-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)'
+ 'ipython: ipconsole plugin')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/exaile/exaile/archive/$pkgver.tar.gz")
+sha512sums=('16b31331a31f0a2e088f177c8a01ef47603b07fe94cbb19869a4caeaec2da03cacaa07d5b0eb50052645449e07620e2c58f202007108af73e20cf744d70bb556')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -44,7 +52,7 @@ build() {
check() {
cd "$srcdir/$pkgname-$pkgver"
- make PYTEST="py.test2" test
+ make PYTEST=py.test test
}
package() {