summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe Tumultuous Unicorn Of Darkness2023-08-05 16:55:36 +0200
committerThe Tumultuous Unicorn Of Darkness2023-08-05 16:55:36 +0200
commit253c2c740d428b217dfc1c10da70d9a1ebf7076e (patch)
tree7956cf6919b3e992601f9ad5ec49ae230f93e955
parent35713e726a6b53d1f2e7b5748af02f3f753806a4 (diff)
downloadaur-exaile.tar.gz
Update exaile to version 4.1.3
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD33
2 files changed, 34 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70ac99a610c0..9b0e562d2071 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,41 @@
pkgbase = exaile
pkgdesc = A full-featured Amarok-style media player for GTK+
- pkgver = 4.1.2
+ pkgver = 4.1.3
pkgrel = 1
url = https://www.exaile.org/
arch = any
license = GPL2
checkdepends = python-pytest
- makedepends = pygobject-devel>=3.22.0
+ makedepends = pygobject-devel>=3.24.0
makedepends = help2man
- depends = python>=3.6
+ depends = python>=3.8
depends = python-bsddb
- depends = gtk3>=3.22.0
- depends = gst-python>=1.14.0
- depends = gst-plugins-base>=1.14.0
- depends = gst-plugins-good>=1.14.0
- depends = python-mutagen>=1.38.0
+ depends = gtk3>=3.24.0
+ depends = gst-python>=1.16.0
+ depends = gst-plugins-base>=1.16.0
+ depends = gst-plugins-good>=1.16.0
+ depends = python-mutagen>=1.44.0
depends = python-dbus
depends = python-cairo
- depends = python-gobject
+ depends = python-gobject>=3.24.0
optdepends = udisks2: device detection
+ optdepends = python-discid: CD info
+ optdepends = python-musicbrainzngs: CD info / Musicbrainz covers
optdepends = spydaap: DAAP server
optdepends = python-zeroconf: DAAP plugins (daapserver and daapclient)
- optdepends = ipython: ipconsole plugin
optdepends = python-pylast: Last.FM integration
optdepends = python-lxml: lyrics from lyricsmania.com (lyricsmania)
- optdepends = python-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)
- optdepends = python-musicbrainzngs: Musicbrainz covers
optdepends = python-feedparser: podcast plugin
optdepends = webkit2gtk: Wikipedia info
optdepends = libkeybinder3: Xlib-based hotkeys
optdepends = librsvg: scalable icons
- optdepends = libnotify: recording streams
+ optdepends = libnotify: native notifications
+ optdepends = streamripper: recording streams
optdepends = moodbar: moodbar plugin
optdepends = gst-plugins-bad: BPM Counter plugin
- source = exaile-4.1.2.tar.gz::https://github.com/exaile/exaile/archive/4.1.2.tar.gz
- sha512sums = 7711f9e062088b02362bbd404f7c61a0f1c128e29e42ce657dc092cac351641f6000846c9da843866bf28ccbd68cf1b07731ba1c9854d52b33c0448e87d0e93b
+ optdepends = python-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)
+ optdepends = ipython: ipconsole plugin
+ source = exaile-4.1.3.tar.gz::https://github.com/exaile/exaile/archive/4.1.3.tar.gz
+ sha512sums = 16b31331a31f0a2e088f177c8a01ef47603b07fe94cbb19869a4caeaec2da03cacaa07d5b0eb50052645449e07620e2c58f202007108af73e20cf744d70bb556
pkgname = exaile
diff --git a/PKGBUILD b/PKGBUILD
index 82929f1f5fbd..89a96a85c20b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,42 +7,43 @@
# Contributor: Joshua Stiefer <facedelajunk@gmail.com>
pkgname=exaile
-pkgver=4.1.2
+pkgver=4.1.3
pkgrel=1
pkgdesc="A full-featured Amarok-style media player for GTK+"
arch=('any')
url="https://www.exaile.org/"
license=('GPL2')
-depends=('python>=3.6'
+depends=('python>=3.8'
'python-bsddb'
- 'gtk3>=3.22.0'
- 'gst-python>=1.14.0'
- 'gst-plugins-base>=1.14.0'
- 'gst-plugins-good>=1.14.0'
- 'python-mutagen>=1.38.0'
+ 'gtk3>=3.24.0'
+ 'gst-python>=1.16.0'
+ 'gst-plugins-base>=1.16.0'
+ 'gst-plugins-good>=1.16.0'
+ 'python-mutagen>=1.44.0'
'python-dbus'
'python-cairo'
- 'python-gobject')
-makedepends=('pygobject-devel>=3.22.0' 'help2man')
+ 'python-gobject>=3.24.0')
+makedepends=('pygobject-devel>=3.24.0' 'help2man')
checkdepends=('python-pytest')
optdepends=('udisks2: device detection'
- #'python-discid: CD info'
+ 'python-discid: CD info'
+ 'python-musicbrainzngs: CD info / Musicbrainz covers'
'spydaap: DAAP server'
'python-zeroconf: DAAP plugins (daapserver and daapclient)'
- 'ipython: ipconsole plugin'
'python-pylast: Last.FM integration'
'python-lxml: lyrics from lyricsmania.com (lyricsmania)'
- 'python-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)'
- 'python-musicbrainzngs: Musicbrainz covers'
'python-feedparser: podcast plugin'
'webkit2gtk: Wikipedia info'
'libkeybinder3: Xlib-based hotkeys'
'librsvg: scalable icons'
- 'libnotify: recording streams'
+ 'libnotify: native notifications'
+ 'streamripper: recording streams'
'moodbar: moodbar plugin'
- 'gst-plugins-bad: BPM Counter plugin')
+ 'gst-plugins-bad: BPM Counter plugin'
+ 'python-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)'
+ 'ipython: ipconsole plugin')
source=("$pkgname-$pkgver.tar.gz::https://github.com/exaile/exaile/archive/$pkgver.tar.gz")
-sha512sums=('7711f9e062088b02362bbd404f7c61a0f1c128e29e42ce657dc092cac351641f6000846c9da843866bf28ccbd68cf1b07731ba1c9854d52b33c0448e87d0e93b')
+sha512sums=('16b31331a31f0a2e088f177c8a01ef47603b07fe94cbb19869a4caeaec2da03cacaa07d5b0eb50052645449e07620e2c58f202007108af73e20cf744d70bb556')
build() {
cd "$srcdir/$pkgname-$pkgver"