summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ece10b59ab9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = exeter-book-hand-font
+ pkgdesc = a font set based on the calligraphic style found in the 10th-century Exeter Book
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://exeterbookhand.com
+ arch = any
+ license = OFL
+ source = https://exeterbookhand.com/EBH-v1.0.0.zip
+ sha256sums = 6787471d7766a8be31f2e601620e402ff43bafd183d626a8df75767e91052af3
+
+pkgname = otf-exeter-book-hand
+ provides = exeter-book-hand-font
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37f496c8f0f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_name=exeter-book-hand
+pkgbase=$_name-font
+pkgname=(otf-$_name)
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='a font set based on the calligraphic style found in the 10th-century Exeter Book'
+arch=(any)
+url="https://${_name//-}.com"
+license=(OFL)
+_archive="EBH-v$pkgver"
+source=("$url/$_archive.zip")
+sha256sums=('6787471d7766a8be31f2e601620e402ff43bafd183d626a8df75767e91052af3')
+
+package_otf-exeter-book-hand() {
+ provides=("$pkgbase")
+ cd "$_archive"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" *.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" license.md
+ install -Dm644 -t "$pkgdir/usr/share/docs/$pkgname/" *.pdf
+}