summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--exim.Makefile14
3 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 706b0c6109fd..3ec4ff636bc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = exim-pgsql
pkgdesc = Message Transfer Agent
- pkgver = 4.87
- pkgrel = 5
+ pkgver = 4.88
+ pkgrel = 1
url = http://www.exim.org/
install = exim.install
arch = x86_64
@@ -24,7 +24,7 @@ pkgbase = exim-pgsql
backup = etc/mail/aliases
backup = etc/mail/exim.conf
backup = etc/logrotate.d/exim
- source = ftp://ftp.exim.org/pub/exim/exim4/exim-4.87.tar.bz2
+ source = ftp://ftp.exim.org/pub/exim/exim4/exim-4.88.tar.bz2
source = aliases
source = exim.logrotate
source = exim.Makefile
@@ -33,10 +33,10 @@ pkgbase = exim-pgsql
source = exim@.service
source = exim.socket
source = exim-submission.socket
- md5sums = 2effc2bd47ad2dc010f655c11a1b1173
+ md5sums = 4cc10c910fd18bb9e299e98bc0a32ed2
md5sums = 4874006f0585253ddab027d441009757
md5sums = e18a535218718c5eb394ed5c9296fe06
- md5sums = 86772117ebb0c0a7580fb5aec96a0da6
+ md5sums = db7e0e61611c45ec8bcc04f0fb58af1a
md5sums = 88cf76405367a6ed371d05db1d3c9565
md5sums = be8fdcf7b2d6b6368a21705e69743265
md5sums = 6f5a5c2b0835b33f59d2513cce18c65b
diff --git a/PKGBUILD b/PKGBUILD
index f003c965d35d..bfb378a0ae9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
_pkgname=exim
pkgname=${_pkgname}-pgsql
-pkgver=4.87
-pkgrel=5
+pkgver=4.88
+pkgrel=1
pkgdesc='Message Transfer Agent'
arch=('x86_64' 'i686')
url='http://www.exim.org/'
@@ -29,10 +29,10 @@ source=(ftp://ftp.exim.org/pub/exim/exim4/exim-$pkgver.tar.bz2
exim@.service
exim.socket
exim-submission.socket)
-md5sums=('2effc2bd47ad2dc010f655c11a1b1173'
+md5sums=('4cc10c910fd18bb9e299e98bc0a32ed2'
'4874006f0585253ddab027d441009757'
'e18a535218718c5eb394ed5c9296fe06'
- '86772117ebb0c0a7580fb5aec96a0da6'
+ 'db7e0e61611c45ec8bcc04f0fb58af1a'
'88cf76405367a6ed371d05db1d3c9565'
'be8fdcf7b2d6b6368a21705e69743265'
'6f5a5c2b0835b33f59d2513cce18c65b'
diff --git a/exim.Makefile b/exim.Makefile
index d8e84b826953..e765f2e94628 100644
--- a/exim.Makefile
+++ b/exim.Makefile
@@ -491,6 +491,16 @@ EXPERIMENTAL_DANE=yes
# Uncomment the following to include extra information in fail DSN message (bounces)
# EXPERIMENTAL_DSN_INFO=yes
+# Uncomment the following to add LMDB lookup support
+# You need to have LMDB installed on your system (https://github.com/LMDB/lmdb)
+# Depending on where it is installed you may have to edit the CFLAGS and LDFLAGS lines.
+# EXPERIMENTAL_LMDB=yes
+# CFLAGS += -I/usr/local/include
+# LDFLAGS += -llmdb
+
+# Uncomment the following line to add queuefile transport support
+# EXPERIMENTAL_QUEUEFILE=yes
+
###############################################################################
# THESE ARE THINGS YOU MIGHT WANT TO SPECIFY #
###############################################################################
@@ -739,6 +749,10 @@ TLS_LIBS=-lssl -lcrypto
# USE_GNUTLS_PC=gnutls
# TLS_LIBS=-lgnutls -ltasn1 -lgcrypt
+# If using GnuTLS older than 2.10 and using pkg-config then note that Exim's
+# build process will require libgcrypt-config to exist in your $PATH. A
+# version that old is likely to become unsupported by Exim in 2017.
+
# The security fix we provide with the gnutls_allow_auto_pkcs11 option
# (4.82 PP/09) introduces a compatibility regression. The symbol is
# not available if GnuTLS is build without p11-kit (--without-p11-kit