summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d100bf0a13ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = eztex-git
+ pkgdesc = A CLI tool for quickly starting new LaTeX projects
+ pkgver = r26.dcb11ac
+ pkgrel = 1
+ url = https://github.com/RubixDev/eztex
+ arch = any
+ license = GPL3
+ makedepends = git
+ provides = eztex
+ conflicts = eztex
+ source = eztex::git+https://github.com/RubixDev/eztex.git
+ sha256sums = SKIP
+
+pkgname = eztex-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d745137c2969
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Silas Groh <rubixdev@mailfence.com>
+
+_pkgname=eztex
+pkgname=$_pkgname-git
+pkgver=r26.dcb11ac
+pkgrel=1
+pkgdesc="A CLI tool for quickly starting new LaTeX projects"
+arch=('any')
+url="https://github.com/RubixDev/$_pkgname"
+license=('GPL3')
+source=("$_pkgname::git+$url.git")
+makedepends=('git')
+provides=('eztex')
+conflicts=('eztex')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname/eztex.sh" "$pkgdir/usr/bin/eztex"
+ mkdir -p "$pkgdir/usr/share/$_pkgname"
+ cp -r "$srcdir/$_pkgname/templates" "$pkgdir/usr/share/$_pkgname/"
+ install -Dm644 "$srcdir/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}