summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD38
3 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05f710f578fa..14bb6a617e37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = factor
pkgdesc = A general purpose, dynamically typed, stack-based programming language.
- pkgver = 0.98
+ pkgver = 0.99
pkgrel = 1
url = http://factorcode.org
arch = i686
@@ -10,14 +10,13 @@ pkgbase = factor
provides = factor
conflicts = factor-git
options = !strip
- source = http://downloads.factorcode.org/releases/0.98/factor-src-0.98.zip
+ source = http://downloads.factorcode.org/releases/0.99/factor-src-0.99.zip
source = factor.desktop
source = factor.svg
source = fuel-factor-vm.patch
- sha512sums = 0f3f7a450023a3d029f7a1b428c8a4e5140619fc3aeea9c416c090cbf981a1b30e1371226eae5b7bda31b67b764ca3eaf84a6c9ae6e19b4b64470fac588fcb39
+ sha512sums = a723e6f06bc798e7770f715e2d8a4163eb684d5a855ecb0e902a265b5aacec19439c7c8c4c4e43b119ad8a536bbd0361adae320e79e58ee90cdb1ec2fe44b005
sha512sums = 19cf98d0fce2f1f65db4d3416c9577aa5e1f9c5829fab8f722756d37d4683caf3c740669ba895660a66177b6b38e3c7a30153ca70a515e91a455b83c4a55a026
sha512sums = 4065a22cd10873f74024655aa71aafa2b96c0e391f61a5e71f5f4fac9b49955428528c2666da5e6e5058aa28347b0f9327575f2467baf9e3914739b8fa0b2c26
sha512sums = 743b7d1332acc9863968686b2182bc9e9fa91822abd8c3b63a7933480b014dce15e86bb69201695186af26a6b267705e0618f131632249b2c3872d85a1973b07
pkgname = factor
-
diff --git a/.gitignore b/.gitignore
index 30dfb5b9c46d..9fa8944edb8b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,5 @@ src/
*.tar.gz
*.tar.bz2
*.tar.xz
+*.tar.zst
*.zip
diff --git a/PKGBUILD b/PKGBUILD
index a12c76f09774..1a8956ee1792 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Leonidas <marek@xivilization.net>
+# Maintainer: Sergii Fesenko <sergii underscore f dot at outlook dot com>
+# Contributor: Leonidas <marek@xivilization.net>
pkgname=factor
-pkgver=0.98
+pkgver=0.99
pkgrel=1
pkgdesc="A general purpose, dynamically typed, stack-based programming language."
arch=(i686 x86_64)
@@ -14,29 +15,31 @@ source=(http://downloads.factorcode.org/releases/$pkgver/$pkgname-src-$pkgver.zi
factor.desktop
factor.svg
fuel-factor-vm.patch)
-sha512sums=('0f3f7a450023a3d029f7a1b428c8a4e5140619fc3aeea9c416c090cbf981a1b30e1371226eae5b7bda31b67b764ca3eaf84a6c9ae6e19b4b64470fac588fcb39'
+sha512sums=('a723e6f06bc798e7770f715e2d8a4163eb684d5a855ecb0e902a265b5aacec19439c7c8c4c4e43b119ad8a536bbd0361adae320e79e58ee90cdb1ec2fe44b005'
'19cf98d0fce2f1f65db4d3416c9577aa5e1f9c5829fab8f722756d37d4683caf3c740669ba895660a66177b6b38e3c7a30153ca70a515e91a455b83c4a55a026'
'4065a22cd10873f74024655aa71aafa2b96c0e391f61a5e71f5f4fac9b49955428528c2666da5e6e5058aa28347b0f9327575f2467baf9e3914739b8fa0b2c26'
'743b7d1332acc9863968686b2182bc9e9fa91822abd8c3b63a7933480b014dce15e86bb69201695186af26a6b267705e0618f131632249b2c3872d85a1973b07')
-
-build() {
- # thanks to qx from #concatenative for the proper SSE settings:
- # i686: no SSE, x87 floating point => _sseversion=0
- # x86_64: SSE2 => _sseversion=20
- _bootimg="boot.unix-x86.32.image"
- # unfortunately, factor 0.94 needs SSE2 to run, so this needs to be
- # set (temporarily?) to SSE2
- _sseversion=20
- [ $CARCH = x86_64 ] && _bootimg="boot.unix-x86.64.image" && _sseversion=20
-
- cd $srcdir/$pkgname
+prepare() {
+ cd $pkgname
# apply patches
patch -p1 < $srcdir/fuel-factor-vm.patch
+}
+
+build() {
+ cd $pkgname
# build the VM
make
- # bootstrap factor with the minimum supported SSE
- ./factor -i=$_bootimg -sse-version=$_sseversion
+
+ # thanks to qx from #concatenative for the proper SSE settings:
+ # i686: no SSE, x87 floating point => -sse-version=0
+ # x86_64: SSE2 => (autodetect) -sse-version=20
+ if [ $CARCH = x86_64 ]; then
+ ./factor -i="boot.unix-x86.64.image"
+ else
+ # bootstrap factor with the minimum supported SSE
+ ./factor -i="boot.unix-x86.32.image" -sse-version=0
+ fi
}
package() {
@@ -66,3 +69,4 @@ package() {
install -D "$srcdir/factor.desktop" "$pkgdir/usr/share/applications/factor.desktop"
install -D "$srcdir/factor.svg" "$pkgdir/usr/share/pixmaps/factor.svg"
}
+