summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3d41d224a40..5daba20b0aa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = factropy-git
pkgdesc = A hobby gamedev project heavily influenced by Factorio
- pkgver = 1
+ pkgver = r102.b52290f
pkgrel = 1
- url = https://github.com/seanpringle/factropy
+ url = https://github.com/factropy/factropy
arch = x86_64
license = MIT
makedepends = git
depends = libglvnd
- source = git+https://github.com/seanpringle/factropy.git
- source = git+https://github.com/seanpringle/raylib.git
+ source = git+https://github.com/factropy/factropy.git
source = factropy.sh
md5sums = SKIP
- md5sums = SKIP
md5sums = b77189e6385420fcc54dcbce0f77e25c
pkgname = factropy-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b7bbb2c36dfb..8add30a9053d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,32 @@
_pkgname=factropy
pkgname=$_pkgname-git
-pkgver=1
+pkgver=r102.b52290f
pkgrel=1
pkgdesc='A hobby gamedev project heavily influenced by Factorio'
arch=('x86_64')
-url='https://github.com/seanpringle/factropy'
+url='https://github.com/factropy/factropy'
license=('MIT')
-depends=(libglvnd)
-makedepends=(git)
-source=("git+https://github.com/seanpringle/factropy.git" "git+https://github.com/seanpringle/raylib.git" "factropy.sh")
-md5sums=('SKIP' 'SKIP' 'b77189e6385420fcc54dcbce0f77e25c')
+depends=("libglvnd")
+makedepends=("git")
+source=("git+https://github.com/factropy/factropy.git" "factropy.sh")
+md5sums=('SKIP' 'b77189e6385420fcc54dcbce0f77e25c')
-prepare() {
- cd "$_pkgname"
- git submodule init
- git config submodule.raylib.url $srcdir/raylib
- git submodule update
+pkgver() {
+ cd $_pkgname
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd "$_pkgname"
- make linux
+ make clean
+ make linux2
}
package() {
cd "$_pkgname"
mkdir -p "$pkgdir/usr/"{bin,share/factropy}
- cp --recursive "$srcdir/factropy/"{font,models,shaders,script,factropy} "$pkgdir/usr/share/factropy/"
+ cp -r factropy assets models font shader scenario LICENSE README.md "$pkgdir/usr/share/factropy"
cp "$srcdir/factropy.sh" "$pkgdir/usr/bin/factropy"
chmod +x "$pkgdir/usr/bin/factropy"
}