summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD27
-rw-r--r--fakeroute.install25
3 files changed, 33 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2960b773a156..959a3c40303c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = fakeroute
pkgdesc = a hack that makes your host appear (to unix traceroute) to be anywhere
pkgver = 0.3
- pkgrel = 2
+ pkgrel = 3
url = http://www.thoughtcrime.org/software/fakeroute/
+ install = fakeroute.install
arch = i686
arch = x86_64
license = unknown
diff --git a/PKGBUILD b/PKGBUILD
index c44b9883e1e1..e212009a5db1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,24 @@
# Contributor: boteium
pkgname=fakeroute
pkgver=0.3
-pkgrel=2
-license=unknown
-source=http://www.thoughtcrime.org/software/fakeroute/${pkgname}-${pkgver}.tar.gz
+pkgrel=3
+license=("unknown")
+source=("http://www.thoughtcrime.org/software/fakeroute/${pkgname}-${pkgver}.tar.gz")
pkgdesc="a hack that makes your host appear (to unix traceroute) to be anywhere"
arch=('i686' 'x86_64')
url=http://www.thoughtcrime.org/software/fakeroute/
+install="fakeroute.install"
md5sums=('d35c1894f2774993e785825f9fd06fa2')
+
build() {
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr
make
}
+
package(){
cd $srcdir/$pkgname-$pkgver
make prefix=$pkgdir/usr install
-
-
-echo Usage:
-echo To use fakeroute, you must define a route file with your fake route.
-echo The file should be a newline separated list of dotted quad IP addresses
-echo For example, 10.0.0.34 could have a route.conf that looks like\:
-echo .
-echo 216.102.187.130
-echo 165.87.161.74
-echo .
-echo traceroute to localhost \(127.0.0.1\), 30 hops max, 40 byte packets
-echo 1 core4-g3-0.snfc21.pbi.net \(216.102.187.130\) 0.324 ms 0.247 ms 0.162 ms
-echo 2 sfra1sr3-so-1-1-1-0.ca.us.prserv.net \(165.87.161.74\) 0.164 ms 0.265 ms 0.159 ms
-echo .
-echo To run, become root, and simply execute "fakeroute -f <route_file>".
-echo .
-sleep 1
-
}
diff --git a/fakeroute.install b/fakeroute.install
new file mode 100644
index 000000000000..38cf809144ff
--- /dev/null
+++ b/fakeroute.install
@@ -0,0 +1,25 @@
+show_message(){
+
+echo Usage:
+echo To use fakeroute, you must define a route file with your fake route.
+echo The file should be a newline separated list of dotted quad IP addresses
+echo For example, 10.0.0.34 could have a route.conf that looks like\:
+echo .
+echo 216.102.187.130
+echo 165.87.161.74
+echo .
+echo traceroute to localhost \(127.0.0.1\), 30 hops max, 40 byte packets
+echo 1 core4-g3-0.snfc21.pbi.net \(216.102.187.130\) 0.324 ms 0.247 ms 0.1$
+echo 2 sfra1sr3-so-1-1-1-0.ca.us.prserv.net \(165.87.161.74\) 0.164 ms 0.26$
+echo .
+echo To run, become root, and simply execute "fakeroute -f <route_file>".
+echo .
+sleep 1
+}
+post_upgrade() {
+ show_message
+}
+post_install(){
+ show_message
+}
+